[SOLVED] ssh issues > Unable to ssh into OSMC

Hi there guys.

I was hoping that you could help me with an issue that I’ve been experiencing

I’ve recently set-up my NAS with all of my media on it
I want to use my RasPi 4 running OSMC as my media centre.

Currently I cannot ssh into the RasPi / OSMC

I get the following error message:

ssh: connect to host osmc port 22: Connection refused

Troubleshooting steps:

  1. I’ve given my Pi a static IP address (via DHCP reservation) on my internal

  2. I can ping the RasPi without any issues (via both hostname and IP address)

  3. I ran a command (on the Pi) to see if ssh is is installed and enabled =
    sudo service ssh status

however I got the following error message:

ssh.service - OpenBSD Secure Shell Server
Loaded: loaded (/lib/systemd/system/ssh.service; disabled; vendor present; 

Active: inactive (dead)

Docs:   man:sshd (0)

Which would suggest the ssh is not currently active


  1. Does OSMC come with ssh enabled by default ?
    (I have read old forum posts that state that it is / should be

  2. How do I install / enable ssh on the Pi / OSMC so that I can access
    it over my network via ssh ?

TIA for any help and advice.

PC details:
OS: Ubuntu 20.04 LTS
OS type: 64-bit
DE: KDE 5.18.8
Kernel: 5.14.0-1051-oem
CPU: 4x Intel Core-2 Q8200 (@2.33 Ghz)
GFX: Intel HD

Raspberry Pi 4

OSMC: OSMC_TGT_rbp4_20220314 / (2022-03-14)

On first startup of a new install there is a series of questions asked with enabling ssh being one of them. It can be enabled later by opening the My OSMC add-on and navigating into services.

Hi darwindesign, thanks very much for the info.

Initially, I couldnt find that setting (I was using the Aeon Flux skin)
So I jumped back to the standard confluence skin,
and found the setting you mentioned.

Here’s how I fixed it:

  • I changed the setting to enable ssh

  • Logged out of OSMC

  • Dropped into a terminal and re-ran the code:
    sudo service ssh status

This showed that ssh was enabled and running

  • I rebooted a couple of times
    and ran the same test as above.

ssh is now enabled and running properly

I was then able to make the requisite changes to the
hosts and hosts.alled files on OSMC
(via the terminal by ssh-ing into the Raspi from my computer)

Thank you very much for pointing me in the right direction
It’s much appreciated !

1 Like

You couldn’t find the add-on since it wasn’t on the home page using that skin or are you saying that the add-on wasn’t running correctly when using Aeon Flux?