SOLVED: Suddenly miserable Wifi Speed with Edimax EW-7811Un on RP B

Edit: I have found the reason for the low speeds.

My router is set to automatically set the Wifi channel and I have many other wifi’s around me.

I played around with the settings and set the channel manually. If I set a high channel number like 13, I get only very low speeds. If I set Channel 1, I get instantly 77Mbit of 150 possible Mbits.

The funny thing is, that most of the Wifi’s around me use channel 1. I always thaought it would be better to use a channel which is not used by other wifi’s.

My router at somepoint decided to switch channels, thats why the problem appeared out of nowhere.

Problem solved.

Hi,

I have been using Raspberry for more than a year now with a Edimax EW-7811Un Wifi and OSMC and everything was running fine. I even used to stream my desktop screen via moonlight app ner-realtime to my raspberry. The wifi connection was more than good enough for it.

But out of sudden, I only get very low Wifi speeds now. My router shows me that the raspberry is only using: 2 / 51 Mbits 2,4 GHz / n / 20 MHz WPA2, 1 x 1

I have changed nothing. The distance to my router and the location of the raspberry have unchanged.

Restarting etc does not help at all.

The WIfi Works flawless in my laptop. I have also bought another new Wifi dongle from TPlink cause I thought, maybe the Wifi dongle is broken, but I get the same low speeds with the new adapter.

Therefore I believe that the problem is some Software sided problem on the raspberry.

Strange thing is that my router shows me that the connected device could use 51 MBits, but is only using 2 MBits.

Apart from the slow wifi speed, my setup is working flawless.

With that low wifi speed, the setup is useless.

What is the problem here? Anyone can help?

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us help you.

I created the logs in myosmc, but don’t know where it was saved, also couldn’t find a post telling where the logs were saved. I uploded the logs via myosmc, but I wonder how you would assign the logs to me.

Can you tell me where to find the logs on the sd card? Under var\logs there is only a dpkg.log.

Using MyOSMC log uploader will provide a unique URL which you can provide here.

I get “could not retrieve url. Copy logs to sd card?” I select yes. But i don’t know where the logs are saved.

/boot

They are on the fat partition of the sdcard, or /boot directory of a running system.

The fact that the log uploader won’t work seems to indicate a network issue. Are you sure that two devices are not being assigned or trying to use the same IP address?

Here is the Log:
http://pastebin.com/MFBTrGMk

I can confirm that this is not an IP sharing issue.

The problem is just the connection speed and it came out of nowhere.

My setup was running fine for many months. I even avoided messing with the system because everything was running fine.