[Solved] Sutitles language to show is not working and scrolling at subtitles breaks KODI sometimes to bootloop

Hello,

Some small problems i have found so far that exists in 3 rpi2, one of them is a fresh new installation i made today.

In Videos --> Subtitles --> Languages to download subtitles for i have English, Greek
When in playback i press to download subtitles (lets say from Opensubtitles) it shows only english subtitles.
Now if in Videos --> Subtitles --> Languages to download subtitles for i erase English and leave only Greek in playback when i try to download subtitles it now shows every language it will find (including greek now).
Now if in the huge list of subs i start navigating down to find the language i want and reach near the end of the list kodi breaks in a sad face.
Sometimes it will boot after that sometime it will start to bootloop until you take power out of kodi and restart it.
The same thing goes on with every subtitle provider (eg opensutitles,podnapisi).

If i have english and greek i can find only english subs.
If i have only greek i will find every damn language of the subs that exist and as i go down the list of subs i will get a sad face and sometime bootloop.

I am not providing logs since i think someone has to navigate me to the correct steps to provide them.

Thanks in advance.


Device: (Rasp Pi 2)

Installation media: (SDcard)

Connection: (Wired)

Power Supply Type: 3A

Peripherals: (USB hub with its own 2A power adaptor, two usb hard disk one has its own power, wifi adaptor, keyboard 2.4Ghz adaptop. ) all peripherals are on the usb hub

Storage Device (incl. Network Sharing Protocol): (2 USB drive)

OSMC version: OSMC July 2015 2015.07-1

XBMC version: (grep Kodi .kodi//temp/kodi.log | head -2)14:40:10 9395.041016 T:1956745216 NOTICE: Starting Kodi (15.1-RC1 Git:Unknown). Platform: Linux ARM (Thumb) 32-bit
14:40:10 9395.041016 T:1956745216 NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)

Codecs: (mpeg2, vc1?) none yet

Audio/Video Output: (HDMI and analog)

Overclocked: Turbo

Config.txt Extras:No

should i try to reproduce with debug on and after crash post logs?

reproducing this is extremly easy.

If you have any reliability issues then disable overclock first.
A debug enabled log may be helpful.

overclock is disabled.

This is happening only when i choose to see greek subs.
Lets say i choose german and greek. I will get only german subs.
English and greek. I will get only english
Only greek. I will get all language subtitles and a kodi/sad face restart if i scroll down the list of subs.

Should i enable debug for everything?
Also should i enable debug and then replicate the sad face restart?

Ok sir, here is the log output with debug everything on, only greek subtitles enabled at Languages to download subtitles for.
After that i started a movie playback, then opened subtitles, pressed on opensubtitles.org, it gave me subtitles for everylanguage that exists for that movie and when i try to go down the list kodi breaks to sad face and then restart.

The log is after kodi breaks.

http://paste.osmc.io/ijokowuwel

for some strange reason i cannot see the logs online so i uploaded again here
http://paste.osmc.io/kegilobote

still cannot see them but anyway here you are. if you need different steps for me to do please advise. damn the log is huge and takes a while to load

looking at logs i see this
14:42:40 65076.941406 T:1957249024 ERROR: Texture manager unable to load bundled file: flags/sr.gif
Still cannot understand where that files is or should be

Still cannot understand why subtitles addons cannot understand that i am asking for greek language.

Does switching to Confluence avoid the problem?

1 Like

The problem with kodi crash, yes indeed it does fix it. So that part of the problem is amber skin problem and exists in every platform i have tested (windows, osx, osmc).
Even with files from amber github, same thing happens.
So that part of the problem has to be addresed elsewhere.

And by the way thank you for your help up to now for this.

The other problem i have with greek language and subtitles to show for, seems to exists in kodi 15, in every platform i have tested (windows, osx, osmc). It stands only with greek language. All other languages work as they should. You choose them and and they are the only languages you see from subtitles providers.
All providers except podnapisi, that suddently from last night started working as it should even with greek.
So maybe a provider problem? you ask from greek something does not go right and the return is every language? That is not a problem for in here anyway.

I would say this threat is solved, from the part of this forum.

I am very sorry for bothering you with idiot things.

Thanks you again and keep up the good work.

If the problem is specific to Amber then best to report it here: http://forum.kodi.tv/forumdisplay.php?fid=203

1 Like