[Solved] transmission-daemon and debian-transmission user


I’m new in this forum, at least as a registered user, so first of all, thanks to everyone for the big work you do here, I have used the information here a lot of times.

In this case, and even going through a lot of posts in this forum about similar issues, I’m not able to find the solution for mine.

I have installed transmission-daemon in the Raspberry Pi using

sudo apt-get install transmission-daemon

after that I tried to setup the /etc/init.d/transmission-daemon existing file changing the USER parameter so it was started with other user instead of debian-transmission which is the one configured by default. After a lot of attempts without success, I decided to replace completely /etc/init.d/transmission-daemon for the one suggested official by transmission here Scripts/initd – Transmission

In this way, I was able to start transmission with a different user.

But I still have a problem and is that, when the device (RPi) is restarted, the process transmission-daemon (don’t ask me why) it’s started with the user debian-transmission. If, after restarting the device, I run this:

sudo /etc/init.d/transmission-daemon restart

It works ok, but the very first start of the system uses debian-transmission user. I don’t know where the f*** is configured to use debian-transmission

[SOLVED] Note: as a magical inspiration, while writing this post I found the file:


Which contains a line that sets the user to debian-transmission and it seems to overwrite what you define in the transmission-daemon init.d script. After changing it there it works ok even after restarting. 

I have to say that none of the tutorials about installing transmission that I have seen talks about this, so it may be that is a problem for other people too. I hope this post helps someone :smile:

It seems that you have tried to find the hard way to do something - we have a pre-configured version of transmission in the OSMC app store accessible via My OSMC - none of the configuration you went through is necessary with this app store version of transmission as it already has a proper systemd service unit and runs as the osmc user…

Edited for accuracy.

Hi guys, I’m new here and I need help.
I’m trying to use OSMC + SICKCHILL + TRANSMISSION on RPi3, but transmission is my problem. I install from (apt-get install transmission-daemon). I create 2 folders, tvshows and incoming. The transmission make download to folder tvshows but the owner stay debian-transmission and sickchill can’t move files because permissions don’t stay apply. I made commands (chmod + 777, chown -R sickchill) and all of new files are donwloaded comming with debian-transmissin like owner.

PS: I tryed install transmission by osmc store and return the error:

What I can do?

Post debug logs.

Did you remove transmission-daemon first?

Hi, I change a lot of things and now i have other problem, I will remake the instalation. I post result here after. Tks for atention.

Yeah, and now I tryied install transmission-daemon again via apt-get and nothing are downloaded, the message error says: do not can write/read on /mnt/…/incoming.

I will remeake instalation. Tks