[Solved] TVHeadend password?


I cannot login to the TVHeadend admin interface anymore.
I’m certain the password I am using is the right one. I am in the authorized local network. I don’t understand what’s going on, since I can watch TV.
Is there a way to regain access without deleting everything? I kinda want to keep the settings



If you using the same password for the client as the addon, its stored in:


Thanks Tom.

Sorry for the delay, I just tested it, well, that doesn’t work :confused:

Do you have an other tip?


If that didn’t work, you will probably have to reset your configuration.

Thanks Tom.

There might be a trick as last chance:

  1. login via SSH as user osmc to the OSMC device running the tvheadend (and web) server
  2. go to /home/osmc/.hts/tvheadend/accesscontrol
  3. there you find a file for each user in tvheadend namely the user osmc
  4. with vi or nano open the file which contains "username": "osmc", and replace the username by an asterix like "username": "*",
  5. restart tvheadend sudo systemctl restart tvheadend
  6. retry to load the web page of tvheadend (might be clearing the browser’s cache could help)

If this works you can continue with the steps below otherwise you’re doomed and have to reset the configuration.

  1. in tvheadend GUI first correct the password of the osmc user at GUI->config->users->password (might be that you have to restart tvheadend before the next step)
  2. secondly correct the username from * back to osmc at GUI->config->users->access entries
  3. restart tvheadend by sudo systemctl restart tvheadend
1 Like

Another way. If your login name is still osmc you can use the default password file and put it in ~/.hts/tvheadend/passwd. It’s called c247bc5760446f232f0d4853fda9c1ff and the contents are:

osmc@vero4tv:~/.hts/tvheadend/passwd$ cat c247bc5760446f232f0d4853fda9c1ff
"enabled": true,
"username": "osmc",
"wizard": true,
"password2": "VFZIZWFkZW5kLUhpZGUtb3NtYw=="

That’s the hash for the default password ‘osmc’.


Thanks a lot! That worked like a charm :slight_smile:


Unfortunately i have the same problem. I have setup TVHeadEnd new and gave my user “dvb” no admin permissions.

How can i access TVHeadEnd with admin permissions now?

osmc@osmc:~/.hts/tvheadend/accesscontrol$ ll
total 16
drwx------  2 osmc video 4096 Dec 14 13:34 .
drwxr-xr-x 11 osmc video 4096 Dec 14 13:39 ..
-rw-------  1 osmc video  706 Dec 14 13:34 542b7bd822c7b64a8976e7acce9cd302
-rw-------  1 osmc video  692 Dec 14 13:34 a98b988b34c0745eb684ba08157f749f
osmc@osmc:~/.hts/tvheadend/accesscontrol$ grep username *
542b7bd822c7b64a8976e7acce9cd302:       "username": "osmc",
a98b988b34c0745eb684ba08157f749f:       "username": "dvb",
osmc@osmc:~/.hts/tvheadend/accesscontrol$ cd ~/.hts/tvheadend/passwd
osmc@osmc:~/.hts/tvheadend/passwd$ ll
total 20
drwxr-xr-x  2 osmc video 4096 Dec  6 11:23 .
drwxr-xr-x 11 osmc video 4096 Dec 14 13:39 ..
-rw-------  1 osmc video  100 Dec  6 11:23 34955b9ba47c018b4f762622afefcb14
-rw-------  1 osmc video  105 Dec  6 11:23 a5e2505a7b69cc162b501c0598c02844
-rw-r--r--  1 osmc osmc   101 Dec  6 11:15 c247bc5760446f232f0d4853fda9c1ff.20211206
osmc@osmc:~/.hts/tvheadend/passwd$ grep 'username\|password2' *
34955b9ba47c018b4f762622afefcb14:       "username": "dvb",
34955b9ba47c018b4f762622afefcb14:       "password2": "VFZIZWFkZW5kLUhpZGUtZHZi",
a5e2505a7b69cc162b501c0598c02844:       "username": "osmc",
a5e2505a7b69cc162b501c0598c02844:       "password2": "VFZIZWFkZW5kLUhpZGUtb3NtYw==",
c247bc5760446f232f0d4853fda9c1ff.20211206:"username": "osmc",
c247bc5760446f232f0d4853fda9c1ff.20211206:"password2": "VFZIZWFkZW5kLUhpZGUtb3NtYw=="


There is a link at the top tvheadend page: (login), click that and login as the osmc, which looks to be using the default password (osmc). You should now be logged in as an admin user.

Thanks Tom.

1 Like