[Solved] TVHeadend password?

Hey!

I cannot login to the TVHeadend admin interface anymore.
I’m certain the password I am using is the right one. I am in the authorized local network. I don’t understand what’s going on, since I can watch TV.
Is there a way to regain access without deleting everything? I kinda want to keep the settings

Thanks!

Hi,

If you using the same password for the client as the addon, its stored in:

~/.kodi/userdata/addon_data/pvr.hts/settings.xml

Thanks Tom.

Hey,
Sorry for the delay, I just tested it, well, that doesn’t work :confused:

Do you have an other tip?

Hi,

If that didn’t work, you will probably have to reset your configuration.

Thanks Tom.

There might be a trick as last chance:

  1. login via SSH as user osmc to the OSMC device running the tvheadend (and web) server
  2. go to /home/osmc/.hts/tvheadend/accesscontrol
  3. there you find a file for each user in tvheadend namely the user osmc
  4. with vi or nano open the file which contains "username": "osmc", and replace the username by an asterix like "username": "*",
  5. restart tvheadend sudo systemctl restart tvheadend
  6. retry to load the web page of tvheadend (might be clearing the browser’s cache could help)

If this works you can continue with the steps below otherwise you’re doomed and have to reset the configuration.

  1. in tvheadend GUI first correct the password of the osmc user at GUI->config->users->password (might be that you have to restart tvheadend before the next step)
  2. secondly correct the username from * back to osmc at GUI->config->users->access entries
  3. restart tvheadend by sudo systemctl restart tvheadend
1 Like

Another way. If your login name is still osmc you can use the default password file and put it in ~/.hts/tvheadend/passwd. It’s called c247bc5760446f232f0d4853fda9c1ff and the contents are:

osmc@vero4tv:~/.hts/tvheadend/passwd$ cat c247bc5760446f232f0d4853fda9c1ff
{
"enabled": true,
"username": "osmc",
"wizard": true,
"password2": "VFZIZWFkZW5kLUhpZGUtb3NtYw=="
}

That’s the hash for the default password ‘osmc’.

2 Likes

Thanks a lot! That worked like a charm :slight_smile: