[SOLVED] Unable to browse my NFS folder shares (But does work on Pi)


Just received the Vero today, updated everything and tried to add my video folder, a NFS share.

I can see my server, see the video folder. but I am unable to browse the folder (or any other of my shares)
My raspberry has always worked properly with the shares, never a problem. The raspberry is at the moment also connected and has normal access to my shares.

I have already set the insecure flag on my NFS Export file:


I can see the folders, but not browse them. I also set a folder to 777, no effect

Can anyone help please?
Do I need to provide a log, what log do you need?

The format of your exports file doesn’t look quite right to me, although I haven’t got a PI or Vero or played with OSMC yet. doesn’t look right, are they the two hosts you are trying to grant access to? Or a range of IP addresses?

It should be in the format :-

export host1(options) host2(options) hostn(options)

Or if trying to do a range of IP :-

The entry = hosts to

Try changing your files and see if that helps, and re-export your nfs shares on your server, probably :-
/usr/sbin/exportfs -r

But would really depend on your server flavour :slight_smile:

Thank you for the advise, the was indeed defined as a range.

I changed the the “range” to for each share and:

  • ran the command sudo /usr/bin/exportsfs -r
  • restarted the NFS server

The Vero can see my shares again :smile:

ps. strange that it always has worked with the Pi