[SOLVED] Vero 2 doesn't play any video after March update

Hi there,

I installed last night the latest March update and now my Vero doesn’t play any video anymore. I rebooted both Vero and my NAS (where all my videos are located) but it still doesn’t play. When I clicked Play, the OSMC logo appears but nothing happens. The movie doesn’t play and it seems like OSMC freezes. I can back out and then I will return to the cover page.

Can somebody help me with this? Which logs I should upload? I really need to fix this as this is the time I will stay home more often due to the corona virus… any help would be appreciated!!

Debug enabled logs as described here

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Okay great for the quick reply! Thanks!

Logs successfully uploaded.
Logs available at <hidden>

Oh just wanna know how to delete the published log later as it contains quite some sensitive info about my library… thank you!

There is no direct way to delete, so I just hidden your post.

Actually just now saw it’s a 1st gen Vero, so maybe same problem as in other thread which neead @sam_nazarko to find a fix

Okay thanks… so what should I do now? Link my current topic there and ask for the fix? Please advise. Thank you.

As I already tagged Sam here he surely will update when there is a fix or he will advice if your problem is different

I just saw an error in the uploaded log. To troubleshoot this problem I temporarily changed my sources.xml but not knowing that the link to the video file was not updated in the central database so it could not find the file to play. I will fix this and re-upload it here when the issue still persists. Thank you for your quick reply!

Support for the first generation Vero ended some time ago and there are no updates for it. Are you sure you have a 1st generation device?

Yeah I bought the 1st generation for sure. I somehow got an automatic update alert so I installed it. I am already happy that my 1st gen still got updates. Not knowing that the support has ended.

The last supported version was 2018.12-1 with Kodi 17.6. You can install this version from our downloads page.

Okay thanks! Do I choose the Vero image (which is not recent anymore) or de OSMC image? How do I flash it to my Vero?

Okay I see it now… that’s the old version. Thanks!

Your log seems to show that you have a Vero 2, not a Vero 1.

Hmm sorry my apology… I really thought I have a Vero… thanks for reminding me that.

I was almost going to flash my Vero with the Vero disk image… do you know what issues I have?

Thank you for responding because you are not feeling well?? Take care!

I would check which device you have before attempting any reinstallation of OSMC.

Yeah I know… but I would rather find out what happened now to my Vero after the March update. Do you think it is related to the problem in the other forum? I would resort to reinstallation of Vero 2 if nothing helps.

If it’s a Vero 2, just wait a little bit and update again and the problem will be solved.

Okay I have Vero 2 otherwise I will not be able to download the March update from My OSMC. I didn’t install it manually.

Thank you for the heads up! I will wait for the fix! I appreciate it!

Take care!