[SOLVED] Vero 4K + died. Not able to start again

My Vero 4k + box died, and I’m unable to start it up again.

There is nothing attached to it, only using the remote.

How shoud I proceed ?

Do you see any lights?

Red light should illuminate for a couple of seconds when booting.

Otherwise you should see a red light by the optical port.

What were you doing with it last? Did you experience any recent issues?

Sam

Thank you for the quick reply.

No, there are no lights. Not in the cross or in the optical port.

I tried to let it run for a while to see if I could see it on the network, but nothing.

I haven’t used it for a couple of days, last time it worked ok.

No, there haven’t been any issues.

If there are no lights whatsoever, I’d suspect the power supply could be the problem.

You could try powering the device from a USB cable.

Cheers

Sam

All right, then I’ll give that a try.

I’ve searched the forum here and it seems like it needs 500mA (That’s 0,5A, correct?)

All my USB-chargers seems to have a larger output than this, is this harmful, or will it only use what needed ?

And is this the type of cable needed?

Yes that cable is correct.

Larger Amps are fine (or even needed). Just the Voltage need to be correct (5V).

Alternative to the USB approach you could also check if you have a fitting power supply, specification: DC 5V, min. 2A, center positive, coaxial power connector male with OD 5.5mm and ID 2.1mm

1 Like

I couldn’t find such a cable in my storage, and I need to order it online.

I do however have USB-C cable and an iPhone charger, but it says 5V or 9V on the charger.

I thought I could use this to see if I get the box started again, but I don’t want to risk damaging it. Is it better to wait for the correct cable?

I got my USB-A male to male cable and an old iPhone charger, and it worked! Thank you all for the help.

For the long run you might want to get a new power supply from your local shop or order from OSMC

1 Like