[Solved] Vero 4k+ hangs on Torrent downloads

Have a Vero with SSD disk attached via USB
I’ve installed Transmission from App Store, once I add torrent for downloading - Vero hangs in 1-2 mins. Rebooting doesn’t help - 1-2 mins and it hangs again. Still able to scp content to ssd without any issue

What speeds are you downloading in? In my case if I pushed data above 5mbyte/s to my NTFS formated drive it would hang while transfers (both FTP and Samba). Didn’t get total system hangin, just the transfer. Finally i limited ftp transfers to 3mbyte/s and had no problems afterwards.

But that’s is to my NTFS volume, i got another Ext4 disk and torrents downloading to that, and that’s always connected to the vero, while the NTFS one does get connected to windows for backing up the mrs “photo collection” from her phone (5-10 gb/month)

If you don’t wanna go Ext4, try ExFAT instead of NTFS.

Not sure about Vero’s speed, but on PC utorrent shows 70-80 mbits over the same wifi and the same torrent. The SSD is formatted as ExFAT

exFAT still has to go through FUSE. You would need to use a native filesystem for better performance

You Ext4? Ok, I’ll try to re-format. Thanks!



I’ve new vero4k+ and it hangs for me also when downloading torrents but this only happens when connected via the internal wifi to either 2.4 or 5 GHz networks (good signal strength, TP-Link Archer C7 router). I’m able to see even 15MiB/s speeds until ssh does not respond anymore, totally hangs and unable to reconnect. Kodi interface and video playing works great though.

This issue does not occur at all when using wired gigabit connection and can see similar speeds, ssh works great.

Any quick tips / ideas what could be causing this? I can do the full support route if nothing comes to mind but currently little busy so wanted to just ask directly.


The WiFi driver is likely competing for CPU time with your torrent client.
I’ll see if I can improve WiFi performance under load.

To reduce the CPU load caused by your torrent client, I’d recommend using a Linux native filesystem such as ext4.

Is there a good guide how to convert USB drive to ext4?
I started from exFat drive auto-mounted to /media/Movies

osmc@osmc:/media$ fdisk -l
Disk /dev/sda: 447.1 GiB, 480103981056 bytes, 937703088 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

 Device     Boot Start       End   Sectors   Size Id Type
/dev/sda1           2 937703087 937703086 447.1G  7 HPFS/NTFS/exFAT

Unmounted the drive

osmc@osmc:/media$ umount /media/Movies/

Converted to ext4

sudo mkfs -t ext4 /dev/sda1
mke2fs 1.43.4 (31-Jan-2017)
/dev/sda1 contains a exfat file system labelled 'Movies'
Proceed anyway? (y,N) y
Suggestion: Use Linux kernel >= 3.18 for improved stability of the metadata and journal checksum features.
Creating filesystem with 117212885 4k blocks and 29310976 inodes
Filesystem UUID: 1ecd14a3-3f16-4e5a-a4b6-ff21ff8e2ed1
Superblock backups stored on blocks:
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
	4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968,

Allocating group tables: done
Writing inode tables: done
Creating journal (262144 blocks): done
Writing superblocks and filesystem accounting information: done

After reboot, USB is mounted

osmc@osmc:~$ cd /media/
osmc@osmc:/media$ ls
1ecd14a3-3f16-4e5a-a4b6-ff21ff8e2ed1  README

Tried to create a file, denied

osmc@osmc:/media/1ecd14a3-3f16-4e5a-a4b6-ff21ff8e2ed1$ touch test.xtx
touch: cannot touch 'test.xtx': Read-only file system

Tried to change permission

osmc@osmc:~$ sudo chown osmc: /media/1ecd14a3-3f16-4e5a-a4b6-ff21ff8e2ed1
chown: changing ownership of '/media/1ecd14a3-3f16-4e5a-a4b6-ff21ff8e2ed1': Read-only file system

First would suggest to give the drive a label so that it is easier on the eyes.
sudo e2label /dev/sda1 nice_name
Then reboot. After

ls -lah /media/
grab-logs -J -K and provide URL

osmc@osmc:~$ ls -lah /media/
total 16K
drwxr-xr-x  3 root root 4.0K Dec 20 17:13 .
drwxr-xr-x 23 root root 4.0K Dec 13 18:22 ..
-rw-r--r--  1 root root  232 Nov 21  2017 README
drwxrwxrwx  3 root root 4.0K Dec 20 17:11 usb_ssd


Looks good, what is output of mount | grep usb_ssd
Is touch /mnt/usb_ssd/test.txt working now or still give read only error?

osmc@osmc:~$ mount | grep usb_ssd
/dev/sda1 on /media/usb_ssd type ext4 (ro,nosuid,nodev,relatime,data=ordered,uhelper=udisks)
osmc@osmc:~$ touch /media/usb_ssd/test.txt
touch: cannot touch '/media/usb_ssd/test.txt': Read-only file system

Ok, based on the label you gave the drive I assume it is a SSD.
My only explanation is that the SSD went into readonly mode (means it is broken).
Maybe try to format it with exfat to see if it is still alive.

osmc@osmc:~$ mount | grep Movies
/dev/sda1 on /media/Movies type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks)
osmc@osmc:~$ touch /media/Movies/test.txt

Thats really strange.
Is the file also still visible after a reboot?

Maybe as a test try to format with ext2 to see if that gives you a rw file system

Yep, even after reboot. Seems ext2 helped

osmc@osmc:~$ mount | grep Movies
/dev/sda1 on /media/Movies type ext2 (rw,nosuid,nodev,relatime,uhelper=udisks)
osmc@osmc:~$ touch /media/Movies/test.txt

And finally I have healthy 60-70 Mbits in Transmission )