[SOLVED] Wireless connection failing after router reset

Hi all,

I’m new to the scene so I apologise in advance for any poor posting-etiquette or lack of basic understanding in some areas.

I have had to reset my home router to factory settings, and in doing so my Pi3 can no longer connect to it via WiFi. Other devices connect fine, my Pi connects via ethernet fine and it can also connect via WiFi to other broadcasting networks, so it’s safe to say the issue lies between my Pi3 and router (Netgear VMDG480). I have rebooted my Pi and router, and moved my pi closer to my router to ensure a good signal, and neither have worked. The link includes logs (apologies for excessive detail here) but having searched for ‘virgin’ (part of my SSID) I can see numerous occurrences quoting:

wpa_supplicant[365]: wlan0: CTRL-EVENT-DISCONNECTED bssid=20:e5:2a:f9:e6:f2 reason=0 locally_generated=1
wpa_supplicant[365]: wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid=“virginmedia5586558” auth_failures=1 duration=10 reason=WRONG_KEY

Now the passphrase to connect to my router is 100% correct and contains no special characters (although it has changed from what it was previously), so would this indicate the public key for the WPA encryption?

I could be looking at the completely wrong thing here, but thought I’d try and offer something.

Debug logs

Let me know if I can give any further info.

Thanks :slight_smile:

Log in via command line
Delete the old network in /var/lib/connman and try reconnect.

Assuming your VM router is a SuperHub, there shouldn’t be a need to reset. The WiFi password, assuming you didn’t change it is usually printed on the bottom or side of it.

I’ll give that a try when I get back home, thanks for the quick reply.

Yeah the admin password had been changed by my fiancée (who didn’t have a clue what it might be) and I needed to change my wpa key so a reset was the only option available.

Thanks again and I’ll update this shortly.

Yep that fixed it, thanks Sam for your help.

New to the forum I thought this was the perfect place to post my issue with my Pi3.

I also had to reset my router Asus AC RT1900 because I forgot the password.

I got everthing to work again via WiFi: 2 Laptop, 3 Phones, Printer, Smart TV all on 5GHz and/or 2.4GHz.

Did use a new password. The new password has one period and two capital letters in the key. I would not consider the period/caps a special character.

The only way I could get the Pi3 (on 2.4GZ.) to be seen by the router is to set the router to a open network. This is indicate to me that the network card on the pie is working.

Does the Pi3 Wi-Fi support 5 GHz?

I did take a image of the network setting on the smart TV.

As soon as I set the router to any encryption, the Pi no longer see the network. This is because there is no password set in the Pi.

I want to OSMC Network and I do not see “Configure Network Manually” as on Setting up your network connection - General - OSMC

So I can not configure it manually, even if I could were do I enter the password?

In the OSMC Network I can see the SSID network name on the right side.

I can enter the encryption key as many times as like but it is not saved and I never see the button to click “apply”

I remove the SD card from the pie and edited the PRESEED.CFD file and only changed the
d-i network/wlan_key string xxxxxxxxxx as that was the only thing that changed.

I reinstated the SD card into the Pi3 and booted up and had no success getting it to work on the network after several attempts.

Any help at this point would be appreciated.

Hi Santashelper,

Firstly, the Pi 3 isn’t 5Ghz unfortunately.

Secondly, have you tried the advice Sam gave me above? I was pulling my hair out trying to erase the network info my Pi had stored for my SSID, and this does exactly that, removes the saved details in the connection manager.

rm /var/lib/connman/wifi_yournetwork_managed_psk

Just reiterating Sam’s advice for me, hope that helps as your problem sounds similar to mine.

Hi I just got back. As far as Sam message go’s I have no clue what he is talking about

I am a Windows guy no Linux but what I understand is you have to use SSH. So once I login where do I go from there? Do you know if there is a tutorial somewhere on the how to get there?

Here is a cheatsheet for how to navigate in a Linux shell: Cheatsheets and Tutorials for users new to Linux based operating systems

I can not ssh into the Pi3
I tried:
username: osmc and pi, Pi
password: osmc and raspberry

Default username/password is osmc/osmc. So if you use that combination what is the error message you get?

Thanks I got it.

Where do I find the file/line that Sam is talking about above.
Thanks in advance

@FailingNetworker wrote it quite clear. Suggest to read the cheat sheet @ActionA referred to than you should be clear what it means