[SOLVED] Xbmc-send giving error

I am trying to run a command to update my video library via SSH (with a view to writing a script that I can run on a cron or on command), but the xbmc-send command is returning an error. This is my input:

xbmc-send --action="UpdateLibrary(Video)"

The error I receive is this:

Traceback (most recent call last):
  File "/usr/bin/xbmc-send", line 29, in <module>
    from xbmcclient import *
ImportError: No module named xbmcclient

If I run a basic xbmc-send --h I get the same error, so it’s nothing to do with the specific action I’m choosing to run.

@sam_nazarko In this thread you say that you have fixed this issue, but it is still not working for me despite being fully updated on my side. Is there something I could be doing wrong? If you need any more info regarding my setup then let me know and I’ll tell you all that I can - I’m not sure what would be relevant here though.


Hey @hlashbrooke!

You can add one line to.
line nr 25.

After add one line…

import sys
import getopt
from socket import *
    from xbmc.xbmcclient import *

Now works xbmc-send


This was fixed some time ago in Git and will make it in to the RC



:wink: I’m late as usual


Thanks @bberski, but that doesn’t seem to work for me. In fact, my file looks a little bit different there regarding the path mentioned.

@sam_nazarko Thanks for the update. In that case, is there a final release date for the RC yet?

Did you edit.
/usr/bin/xbmc-send ?


@bberski I was in the correct file, but I was editing in the wrong place. I just rechecked it and it’s working now :slight_smile: Thanks for the help!

Thanks for posting a fix for this :slight_smile: