Some Addons end up in a blank screen

Since a couple of days some of my addons (netflix most importantly) behave in a very strange way, I’ve tried to post on the github of the add-on and it turn out to be a problem with the OSMC skin, cause when I switch to the Kodi default skin everything works perfectly.

Anyway, when I lunch the add-on I’m able to browse it but where a list of the playable items should appear I get a blank screen (Imgur: The magic of the Internet). did anyone of you ever experience this?

RPi 3B+
OSMC 2020.01-2
Kodi 18.5

log hastebin

Hi,

2020-03-15 12:00:27.162 T:1915217456    INFO: ADDON: cpluff: 'Could not read plug-in directory /usr/lib/kodi/addons: No such file or directory'
2020-03-15 12:00:27.163 T:1915217456   DEBUG: ADDON: cpluff: 'Not all directories were successfully scanned.'

Looks like filesystem corruption, resintall should resolve the issue and depending on the the sd card; it may be worth considering replacing that as well.

Thanks Tom.

this might be a very stupid question, is there a way to perform a new installation of the os, without losing my settings/addons/repository ?

The My OSMC add-on has a userdata backup/restore option in the updates section.

2 Likes

Perfromed a clean install, I got the same problem. hastebin

I don’t get why it works with the kodi skin. I don’t know what else to try

Can you please run grab-logs -A from the command line and provide the URL it returns.

For some reason, I can’t read the log you posted to paste-kodi.tv. Please use https://paste.osmc.tv when posting OSMC logs.

here, sorry, it seemed the same to me :smiley:
https://paste.osmc.tv/aqazixikow

Hi,

Have you installed to an new SD card? If not, that would be the next step.

Thanks Tom.

I just installed it on a new SD card and it works with a new install, restoring from backup gave me the same problem. Can someone explain me what went wrong? is it safe to use the old SD card for other purpose or should I just toss it?

Thanks in advance

That would be difficult. It would seem that something got corrupted with your install. You could put it in a PC, format it, and use something like h2testw to try to figure out if it is defective. There is no assurance that this would pick it up, but if it did it could be reasonably assumed to be the cause. Otherwise it is anyone’s guess what happened.

1 Like

thanks, I’ll try this. finger crossed!

Ok, after few days, I’m getting the same exact problem.
everything worked fine in the beginning and now I’m getting this, what am I doing wrong?

https://paste.osmc.tv/cajajeyife

I’d suggest starting over again, and this time don’t add the suspicious looking repository and addons that you installed.

1 Like