Some DVD images stop playing after 20 sec

OSMC version: 0.9.9 (RC1?)
Kodi version: “compiled Apr 17 2015” (i.e. updated today and rebooted my Pi)
Raspberry Pi version: B

Most DVD images play just fine. But I’ve got some images that stop playing after 20 sec. You can skip, say, 30 sec. and then again playback stops after 20 sec. I have the mpeg2 licence.

Said DVD images play just fine in VLC on my PC. Can I install a different DVD player than the default one in Kodi? This used to be possible in XBMC and solved some problems for me in the past. Is it possible to use VLC as video player in Kodi?

I might upload this DVD image to Dropbox but then I need to upload at least 1 GB of data for the problem to reproduce (I tried to truncate the first VOB to 10 minutes which resulted in an unreadable DVD image).

I hope the prob. can be solved without having to upload that large amount of data (it will take a l.o.o.o.o.n.g time w/ my upload speed).

Please upload a debug log

S

Forgot all about the log! Here it is:

And w/ verbose logging of the video component:

And w/ FFMpeg verbose debugging:

You seem to have problems with network permissions:

18:12:47 T:2751038496 ERROR: NFS: Failed to stat(home/michel/downloads/complete/Saterday Night Live - The best of Eddie Murphy/VTS_01_1.VOB) stat call failed with "NFS: Lookup of /Saterday Night Live - The best of Eddie Murphy/VTS_01_1.VOB failed with NFS3ERR_NOENT(-2)"

Does it play if you copy to usb stick or sdcard and play from there?

Exactly the same problem then (external drive). Hangs after exactly 10 seconds too. I have no drives connected directly to my Pi (I can connect an USB disk drive if want to however). I play all DVD’s (images) via NFS. I play physical DVD’s via Samba. And that works well, except for a few…

Log file when playing from USB:

I meant play from USB or sdcard direct from Pi, rather than through network/nfs.
I’d like to confirm if it is a general dvd playback issue or a network (probably permissions) issue.

That’s exactly what I tested in my previous reply. :slight_smile: I copied the problematic DVD to an USB hard drive and tried to play it. Same problem, even without network/NFS.

Not really following. Your previous response seemed to still describe playing the DVD over NFS:

18:12:42 T:2751038496   ERROR: NFS: Failed to stat(home/michel/downloads/complete/Saterday Night Live - The best of Eddie Murphy/VIDEO_TS.IFO) stat call failed with "NFS: Lookup of /Saterday Night Live - The best of Eddie Murphy/VIDEO_TS.IFO failed with NFS3ERR_NOENT(-2)"

Have you tested playing the file directly from the Pi (with no network involved)?

Yes I have. Maybe I did something wrong w/ the debug log. I deleted all info from /home/osmac/.kodi/temp/kodi.log and rebooted the Pi. Then this is the log when I try to play the VIDEO_TS folder from a hard drive connected directly to the Pi:

If I’m not mistaken this debug log does not contain any errors about NFS. It appears to stop playing at 14:14:14 w/ the message: “DEBUG: CDVDPlayer::ProcessSubData: Got complete SPU packet”. Some minutes after that I pressed Stop on my keyboard (i.e. X) and after that some more messages are logged.

Do you need any component specific logging enabled?

[edit] FFMpeg specific logging: http://pastebin.com/rCCpFMf1
Video specific verbose logging: http://pastebin.com/DBtkVUXe

I’ve asked this question in the Kodi forum too (link). But nobody replies unfortunately. Doesn’t anybody here know what might be wrong from reading the debug logs my reply from May 12 2015? Please?

The problem appears to be the video acceleration.

See this topic reply #8. When MMAL and OXM video acceleration are turned off then DVD’s play fine. The big question remains: is the buggy acceleration a Kodi problem or an OSMC problem?

P.S. It seems that Kodi 15 ‘Isengard’ might solve this problem as the DVD player has been rewritten for it. Hope OSMC will support it very very soon!

I have the same problem. My home situation is as follows:
In the living room is a HTPC with Windows 7 and Kodi. In my home-office is a Linux-Ubuntu PC with Kodi. In my bedroom and another room are two Raspberry Pi’s with Openelec. Every computer connects to the LAN.
A DVD TV-show, ripped from an original DVD can be played on the living room PC. It can also be played on the Ubuntu-PC. But playing it on the two Raspberry’s causes the problem MeneerJansen describes. After approx. 20 seconds the player stops playing.
I have tried to rip the TV-shows with DVD-shrink and DVD-Fab. I have also created ISO’s but it makes no difference. The only difference is using DVD-Fab and rip the show to a MKV-file. In that case it works fine.

So are you asking for support on your OE pi’s? Because this is OSMC support forum.

Good point. But the problem lies in the video acceleration (MMAL and OMX) so in this case the problems for OpenElec and OSMC are the same. Mr. Popcornmix appears to have rewritten the DVD player part of Kodi. His “fix” will be included in Kodi ver. 15 ‘Isengard’.

@Berber: OE seems to be able to run a beta version of Isengard. Maybe you can try that. If that helps then we know for sure that the video acc. is in fact the problem. [edit] In this forum somebody did use the beta Isengard version. To no avail elas…

Sure hope somebody will tacle this problem soon… It’s very frustrating not to be able to play back DVD’s on a Media Center. :cry:

P.S. Does somebody know how to downgrade OSMC or Kodi? There must have been a version that plays DVD’s well.

If anyone can provide a sample ISO file that shows the problem I can investigate.
Ideally use a DVD editing tool to edit the size down (i.e. remove the main feature or edit it down to a couple of minutes).

Sorry about the two topics that I started about this (link). But like I asked in the other forum: I use Linux for my OS. What DVD editor do you use/recommend?

Here’s a sample mpeg2 file that won’t play (cut from a DVD with out re-encoding): Dropbox - File Deleted It stops playing at aexactly the same time as the DVD I cut it from.

Thanks I can reproduce. There is something in the stream the HW decoder doesn’t like that results in the stall.
I’ve forwarded it to our codec expert.

Dying to know what the codec expert says… :wink:

Awfully sorry to bump, but… bump.