Some DVD images stop playing after 20 sec

Sorry about the two topics that I started about this (link). But like I asked in the other forum: I use Linux for my OS. What DVD editor do you use/recommend?

Here’s a sample mpeg2 file that won’t play (cut from a DVD with out re-encoding): Dropbox - File Deleted It stops playing at aexactly the same time as the DVD I cut it from.

Thanks I can reproduce. There is something in the stream the HW decoder doesn’t like that results in the stall.
I’ve forwarded it to our codec expert.

Dying to know what the codec expert says… :wink:

Awfully sorry to bump, but… bump.

Sorry, codec expert is off sick, so no news.

Sorry to bump again. Has the codec expert replied yet?

In this OSMC forum topic people mention that the some DVD’s play fine and others don’t. I think that they have the same problem. I’m afraid its beginning to get a bigger problem day by day. Maybe a higher priority in solving this prob. is needed?

Confirm see this on a real DVD player on Rpi2.
After disabling MMAL and oxm video everything works as expected or i have not found a faulty dvd yet.

@taiebot Thanks for the info! Lets hope that the developers can solve this bug very soon because, without hardware video acceleration of the GPU, watching video is pretty much impossible on older Pi’s.

@devs: any progress yet on the problem?

I am sure that @popcornmix will update this thread when he is able to provide some news, but he is aware of this problem and it is likely on his (long list) of things to do.

Thanks for your patience.

Sam

Thanks for hearten us up. I’ll be patient. :slight_smile:

Awfully sorry to bump, but: bump. Any news or progress?

Sine May 21 no progress has been made on this, am I right. I don’t want to be pushy: but is there anybody still working on it?

I would suggest that since Isengaard includes so many improvements in player performance and that it’s release is so near, no one is going to spend much time unless the issue is still present in Isengaard after release.

Thanks for the ifo. In my May 20th reply I posted a link to a topic the Kodi forum where somebody updated to a beta version of Kodi ‘Isengard’ (see post #20 there). First indications are that the video player improvements that kind Mr. Popcornmx made for Isengard do not solve this problem. But we’ll see when Isengard comes available for OSMC. :slight_smile:

Any indications on when Isengard comes to osmc?

See the Kodi forum for a workaround. It’s the firmware that’s the problem. But w/ an older version of the firmware the Resume function of OSMC/Kodi crashes. What a pity…

We are very near our Isengard release and we will update the Pi firmware too

Sam

Updated OSMC today to Kodi 15 ‘Isengard’ (link w/ info). The “problematic” DVD’s that I talked about in this forum topic hang again after 20 secs. So the firmware that comes w/ the latest version of OSMC is the one that has problems. Downgraded my firmware to the version to which Mr. Popcornmix posted the link and the probs are (mostly) gone. With that FW version some video’s do not resume playback, as mentioned in this Kodi forum topic.

My “problematic” DVD plays fine with latest OSMC release: no more hangs after about 20 sec.
OMXPlayer & MMAL acceleration are both enabled.

For me the bug is gone, maybe the thread can be marked as SOLVED?

Thank you :grinning:

Indeed the latest version of OSMC comes w/ firmware that does not have this problem anymore! Can you tell me how I can mark this topic as “Solverd”?