Some issues with the November Update on my Vero4k+

Hi together,

just wanted to share some issues that occured at least with the November-update:

  1. Tried to update my OSMC running the June version with the internal updater which leads to a total crash (any start ends with a sad smiley and a reset). Thus I had to setup the OSMC from scratch, using the Image-file. As I had to configure all my shares again, I realised the following thing:

  2. I cannot browse via SMB the network any more. The browser remains empty (just the “…”). I have not change the smb-protocols on my NAS. I set the lowest version to “none” and the highest to “SMBV1” on my Vero4k+. This is the same setup I also run on another Vero4k. I tried to check that on the second device and realised that also on this device I cannot browse the SMB anymore (knowing that it worked before). The only chance I have is to add another network-share manually, directly entering the IP-address and the share of/on my NAS. I also started NFS, which is working fine, but cannot be used on encrypted folders, of which I have one.

  3. Running Vero4k+ in 1080p@60Hz results in permanent handshake-problems. The setup is as follows: Vero4k+ -> Receiver -> Projector; I changed the cable, I changed the HDMI-port of the Receiver without any success. Switching to 1080p@50Hz is working fine unless the Vero4k+ does not get too hot (that is an assumption from yesterday night, when the temp. of the Vero4k+ was up to 78°C and the same issues occur like at 60Hz - what never has happened before). 24Hz runs without any problem.

Does someone has the same issues or some ideas regarding a work-around?

Tabaluga

That means just Kodi was crashing, this could have been fixed via SSH no need to reinstall.

Thanks, could you please post a short description / link to a description, what to do next time?

Well there can be two reasons:

  1. An incomplete update. Then you can continue the update with:
    sudo apt-get update
    sudo apt-get dist-upgrade

  2. A configuration issue in KODI which you could try to figure out with a clean config first

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

1 Like

Great, thanks a lot. Already made a copy of the config to an USB-stick.

Is your “NAS” a Windows 10 PC? If so then likely MS disabled it as it does that automatically after so many days unless certain conditions are met. The other thing that may have happened is that if you restored from a backup the smb credentials, if you were using them would be missing. In this case adding a network location and manually specifying the computer with credentials should make the existing library work again.

No, it is a QNAP-NAS. Windows can access all the shares without any problem.

Now I am a bit lost :wink: I did a restore of a backup with the backup-addon. What should I have done addiotionally?

Did you use the “backup” add-on, or the backup function in the My OSMC add-on? If the former then you would need to provide some debug logs with you trying to play something to gain some insight as its default settings should have grabbed the relevant files. In the case of the My OSMC backup it seems to currently lack the option to grab passwords.xml from the masterprofile, which is problematic.

I used the “backup” add-on, recovering the last backup of November (based on the June-version).

I had checked that backup add-on recently in OSMC when it came up in another thread and I didn’t find any issue that would have caused the issue your having. I just checked it (on a PC for efficiency but should be no different) using default settings in the add-on setting nothing outside of defaults other then the backup location. I removed all existing userdata and recovered from the backup without any issues to be seen. All files relevant to a common Kodi setup were covered including the credentials file for Kodi smb paths.

If you would like to post logs this may allow us to gain some insight. Off the top of my head the only things that come to mind would be if you were using a system mount or Kodi profiles and didn’t check the option to include them in the backup settings.

  1. I had the same crash after the update. Moved the .kodi dir to .kodi_old via ssh and it worked again. Reinstalled though after posting the logs to this forum. (some days ago)
  2. Some years ago, nfs network browsing via kodi on qnap made the qnap “nfs daemon” (don’t remember exactly) crash. It was a QNAP bug that was later fixed by QNAP. I had to downgrade the QNAP FW (with the help of support) before a firmware fix. So the kodi browsing made the daemon crash and then all devices couldn’t access the share anymore. Try restarting the Qnap and try and access with your second device.
  3. what is a handshake problem ? I experience stuttering with live tv recently (tvheadend)…File Streaming works. I have “played” with the refresh rate, so I thought it was related. Didn’t think that this could also be a FW cause. This is not the device that I reinstalled.

Thanks, I will try to do it next time, when the issue happens again.

NFS is working fine for me and the only solution for the time being to have a browsable network-environment. The issues are caused by the SMB-protocol. I am using a TS-451A running QTS 4.5.1.1495… So if someone has an idea…

Hm, maybe handshake problem is the wrong expression: It results in the fact that after a certain time (generally something between 30-60s after I switched to 1080p@60Hz) the projector lost the signal for a moment, the screen went black and then appears again (overall 3-5 s). This is happening regularly every 30-60s. It could also be that there is an issue between the receiver and Vero4K+… The Pioneer SCLX-503 I am using has the latest firmware update installed…

Maybe somebody has an idea what could be the reason for this habit?

In Kodi when you browse for a network share there is an option to “add network Location”. If you did this and in the path entered ONLY the IP address or machine name along with the credentials then this would add a new path that would be browsable to add new sources from without NetBIOS being available.

You could as tests bypass the AVR and or swap cables. You could also try enabling lock HPD is display settings.

I did already swap cables and HDMI-Inputs without success. I directly connected the Vero4K+ with the projector and it seems that the issue is not appearing any more - but I will do a longer test on this soon. I will also test a raspberry pi and check the 1080p@60Hz issue and will report.
Anyhow, the receiver has a lot of other players attached (amazon fire stick, UHD-Player, …) without any issues.

How do you access the Vero4K+ via SSH if it is not booting? As my one did permanently crash during the boot procedure.

Try checking your router to see if it’s getting an IP address.

If I remember well only Kodi was crashing an kept restarting. The underlying OS was up an running.