Some media fails to play after Krypton upgrade

Some media in the SVTplay addon does not play after the update. It shows buffering in the top right and then shows time progress. If I back out enough I get a garbled image. This particular stream worked fine in teh previous version of kodi.

Mediainfo for the stream that doesn’t work:

Format                                   : MPEG-4
Format profile                           : Base Media
Codec ID                                 : isom
File size                                : 443 MiB
Duration                                 : 22mn 7s
Overall bit rate mode                    : Variable
Overall bit rate                         : 2 801 Kbps
Writing application                      : Lavf57.41.100

ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L3.1
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 4 frames
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 22mn 7s
Bit rate mode                            : Constant
Bit rate                                 : 2 700 Kbps
Width                                    : 1 280 pixels
Height                                   : 720 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 25.000 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.117
Stream size                              : 428 MiB (96%)
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709

ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : HE-AAC / LC
Codec ID                                 : 40
Duration                                 : 22mn 7s
Bit rate mode                            : Variable
Bit rate                                 : 96.0 Kbps
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz / 24.0 KHz
Compression mode                         : Lossy
Stream size                              : 15.0 MiB (3%)

Can you send me a sample file?
Try toggling Adjust Refresh Rate as well.

How do I adjust the refresh rate?

I run swedish GUI, so the one that has the options (on - off - at start/stop) ?

I tried all three options without success

Did you restart Kodi each time you made a change?

No I did not. It was set at start/stop.

Will try to disable and restart kodi then.

Tried setting it to off and rebooted system - it changed the language to english… It didn’t help though.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload some logs. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Without mediainfo for the stream it’s impossible for you to figure out what’s wrong,

There seem to be a bit of info in the logs:

You have not enabled debug logging as directed in the very explicit instructions linked above. This means the logs provided contain much less description of the issue Kodi is reporting…

Sorry about that, more verbose logs:

This is a fresh reboot, enable debug log, starting the stream.

Any ideas on this? I just had a chance to test the exact same stream on OSMC running on an RPi3, and there it works, so it seems to be a device specific problem.

Did you try the clock improvements?

1 Like

The refresh rate changes? I tried all options with no success. Anything in the logs that stand out?

These clock improvements…

1 Like

Ok, thanks, will try this weekend.

I tested the stream on the Vero 1, and it works there.

So rpi3 and vero, but not vero 2

just got the family away from the TV long enough to test the clock patch

 wget "" -O vero2-mediacenter-osmc.deb
 dpkg --info vero2-mediacenter-osmc.deb
 Version: 17.0.0-4
 sudo dpkg -i vero2-mediacenter-osmc.deb
 sudo reboot

Installed it and gave it a go - the problematic clip now starts fine! Thanks! @ActionA @sam_nazarko

Clock improvements are now released to all users as a hotfix, so I will close this thread.