Some questions about Vero4k+ (videos out of sync, stuttering)

Hi everybody,

Previous weekend I received my Vero4k+ to replace my old WD Live TV. OSMC and Kodi are new to me so after a while I finally had it set up and was able to access both the external drive and Vero4k+ through the network and I can add and remove media, thanks to some helpful threads on this forum. Have been using the device for some time this week and all without trouble until yesterday.

My questions / issues remaining which I haven’t been able to find an answer for, are the following:

1: Is it correct that when the Vero4k+ is in operation, the front led shows no color?
2. When I shut down the Vero4k+, how do I turn it back on without having to remove the powersupply and plug it back in?
3. The device is sometimes getting quite hot, up to 68C. Is this normal?
4. Some videos appear to play too slow. The sound plays like it should but the video is lagging behind a lot. The exact same files play perfectly with VLC Player on my computer and both videos are located on the external HDD connected to the Vero4k+. I noticed that these specific videos sometimes stutter a bit during playback, but again only the video, not the audio. Both files are 1080i and 1080p so nothing exotic there as far as I can see. Any idea what’s causing this and how I can fix this?
5. Since today the Vero4k+ is also stuttering in some videos, every x minutes a small hick-up. Any ideas? Menu seems slower too.

Thanks in advance.

You can’t. It is intended to be left running.


You would need to post some logs with debug turned on during playback for anyone to try to get to the bottom of that. See [here]

An obvious question there is, how are you powering the drive? Does it have its own mains plug, or does it draw power from the USB socket? And, if it draws power from USB, is it connected directly to the Vero 4K+, or are you using a powered USB hub?

Thanks for your replies. In the meantime I found the suspend option which is sort of a standy function. In suspend mode it’s still accessible through the network and a simple click on the Home-button of the remote wakes up the device, which is nice.

I will have a look into the debugging tomorrow and come back to you.

Good question. The drive is powered by it’s own mains plug and is connected to Vero4k+ through USB. So it’s not drawing power from the Vero4k+.

That won’t be a problem, then. (Just checking!)

  1. Yes.
  2. Go to Power → Suspend instead of Power → Shut Down and you can turn it on by pressing any button.
  3. Yes – the device can run up to 120C where we then engage in a thermal shutdown.
    4/5: we need to see some logs.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:



Hi Sam, thanks for your response. We communicated earlier through email, thanks for that as well. Apologies for the belated reply, life kind of got in the way and eventually creating the log was easier than I thought.

The URL to the log is:

I ran one of the videos for about 1,5 minute. The audio seems to play fine, but the image is lagging behind. In the ± 1,5 minute the video stutters 3 times, as if it seems it wants to catch up but it just can’t.

Really hope the log is useful and this issue can be resolved, it happens on a lot of videos.

Many thanks for your time.

Thanks, I’ll check this shortly


We recommend people with 4K TVs set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K.

*Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

In summary, without a whitelist Vero will not match the output resolution to the video if the video resolution is less than the desktop resolution. Your 1080p25Hz video is being converted to 2160p30Hz which is a lot to do. So change the desktop to 1080p or implement a whitelist that includes 1080p modes.


Thanks @grahamh . I set the device back on 1920x1080p, whitelist was already empty and the 3rd option was already set at On start/stop. Changing the resolution of the interface fixed the lagging of the video so that’s a first. Should I still keep the 30 fps or change that too?

I remember I set the interface to 3820x1920 because the interface is not adjusting to the TV’s size, so not everything fits on the screen:

What would be the solution to this?

Make sure you are not using Kodi’s ‘calibration’ function and set your TV so it doesn’t overscan. The name of that setting varies between manufacturers.

1 Like

Generally speaking, you want to set the UI refresh rate high (60 or 59.94) because it makes the UI more responsive - the gap between when you press a button and when you see the display update is shorter. 50 is also okay, but lower that makes things feel noticeably less snappy. So long as “Adjust display refresh rate” is set correctly, Kodi will change the output refresh rate to match the frame rate of the video when you actually play something.

1 Like

It seems you have a issue with Overscan. Ensure that you did not have any calibration configuration in Kodi/OSMC and use one of the following methods depending on the TV Brand you use.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off

The calibration function wasn’t helping, it was just to move the image to the right position. However, the TV overscan option was set on 'auto and I’ve set it on ‘on’ and it Kodi was fine! Really glad I’m fixing issue after issue with your help.

Thanks! I’ve set it to 59.94 FPS and it indeed feels more snappy, that was one of the tiny issues I was still wondering about. Great stuff!

1 Like

I just wanted to say thank you for this post, because this just solved an issue I had been randomly encountering with certain videos, mainly in the form of skipping/stuttering/loss of sync. Went with your settings recommendations and it fixed the problem instantly. This had been plaguing me for months and I finally decided to do some Googling on it.

Thank you again!

1 Like