Something changed on my pi1 after the update...wifi problems

I got a spare pi1 model b running osmc and the recent update broke it…It brings a sad face then restarts the mediacenter then again the same thing in a loop.
I cant get inside the drive to grab the log, but from what i saw doing a ‘vi’ the log stops right after the OpenGL drivers fire up…after that nothing.

I am gonna reformat…i just wanted to give a heads up


If you can vi the logs, you can get to the command line. If you haven’t formatted already, please issue the following command:

grab-logs -A

And provide us with the url. It should help resolve.

Thanks Tom

I would if the damn thing could connect to my wifi…i ended up reformating.
Its all good now.

While you can “vi” the Kodi log, under systemd the system log is held in a binary format and the kernel (dmesg) log is, AFAICT, only held in memory for the current system run, with no details being kept on disk for previous runs.

If you can attach an Ethernet cable you can ssh in. There are other ways to access the command line (as outlined in the Wiki).

There don’t seem to be any other reports of issues with the update on Pi

I hooked it up to both wifi and cable but the pi couldnt get any internet. I gave it 4-5 tries…and then i remembered last year the same thing happened with the pi2 after an update, so thought not to go through the same trouble again, and just reformat.

i love the titles that states that the upgrade broke my machine… got mine on autoupdate for the lasts couple of updates and no issues its all about config and setup.

If you got broken setup or bad hardware your gonna run into issues and that is the bottom line, updates rarely breaks systems unless you got dodgy addons or bad hardware… and sadly we rarely get any debug logs from users with these issues all we get is a forum post stating that the update broke the system…

I reinstalled osmc on my pi1 about 3 days ago…it updated today and then broke. The only addon it had was BBC player, and that wasnt even set up yet.
Like i said…this happened again 2 years ago on my pi2 (Manual update from OSMC, broke my kodi (RC1) - #16 by Sandbird)…after the update, the pi wouldnt boot up…
So 2 different SD cards, 2 different Pi, same OS, same problem.
I am not blaming anyone…the pi1 is a pretty old device…i knew that things might go south with an update…it barely holds it together.
I just wanted to inform that it happened…on a pi1. Just a +1 to the stats table :stuck_out_tongue:

You are right about the title… i dont know what i was thinking when i wrote it…it should be : Update broke osmc on a pi1 (fixed)

Or better yet dont report it cause it wont help Sam and it wont help you since you reinstalled anyways, the only way it helps if you get a proper debug log when its broken, that is the solution.

The problem really is that it scares users. They think that OSMC’s latest release is broken so they don’t update.

Two years ago (link to your post) was April 2015. The stable release of OSMC 1.0 was in June 2015. So it’s possible there were issues then. But they would have been resolved by now.

Things should be stable now. I’d be wary of your card. It may be about to fail.

I totally agree with you…thats why i thought it was important to mention it was a pi1, so other pi1 owners might wanna do a backup first…cause you never know…pi1s are almost obsolete, maybe something went wrong in their case.
The update on the pi2 went fine…and since this was a pretty fresh setup on the pi1, i thought i should mention that something went wrong.
You know that i am a fellow coder…and if there was even the smallest bug/problem/something with my releases, i would like to know about it…even if it was just a random thing.

(The SD card was brand new…which is the reason why i re-setup the pi1 in the first place.)

There have been quite a few Pi 1 (and Pi Zero) users that have updated without

Unfortunately without any logs it’s hard to speculate what the issue is

I know…but i couldnt get the pi to connect to the internet :confused:

Logs can still be pulled without an Internet connection.

So…a month has passed and the pi started acting up again after the update in August. It started doing something that it was doing last year…It loses the wifi connection for no apparent reason.
I tried the rc.local trick that we did last year…(with the iwconfig wlan0 power off) in case it was a power bug left over in the update, but that didnt help.
It even dropped connection while i was using it today.
I tried a manual update yesterday, and it updated to the 17.4 version…but obviously that didnt help…since it happened again today.

Latest log:

ps: It’s not the power supply. I bought a new one, since you guys keep saying to all my pi1 problems that it’s the power supply…