Sometimes loosing video input when starting playback (Vero 4k)

Hello all,
My first time reporting an issue here so please bear with me if I’m missing something.

I have no definitive proof it is the culprit, but I have been experiencing an issue on my Vero 4K since installing the october update. (never ever happened before the update, but coincidences do happen)
Sometimes when starting playback of movie, series, or stream, TV suddenly looses video input, as if the Vero had crashed/shutdown. However, it still has the blue light, and I can SSH on the box when it is in that state. Switching TV input, or powering off and on the TV doesn’t help.
So far, pulling the power from the Vero, then restarting the exact same series/movie, has always worked. I never saw this issue twice in a row for a single source.

I was not too sure how to word this, so I apologize if this issue is already mentionned in another thread explained differently.

I have enabled Debug and uploaded logs:

Please let me know if I can provide any other info. THanks!

I am having similar issues. I keep the Vero 4K+ on always even if I shut down the TV (Samsung 4K).

If I turn on the TV once in a while I don’t get a picture, but a message on the TV the HDMI signal isn’t recognized. Sometimes it works, but as soon as I start a video I get a black screen and message again.

So it looks like something is going wrong with HDMI handshake. Vero an TV are connected directly. Never had this issue before the latest update with handshake and 4K improvements.

Log file: Https://


Can you turn on debug logging and grab the logs again, please, and describe exactly what was happening while the log was being collected?

Yes of course. Will do so.
Is the privious log file incomplete?

Thanks. Just go Settings-System-Logging and turn on Enable debug logging.

New log file uploaden:

Fresh restart
start a video to see if it works oke.
Stop video
Shut down TV
Wait a few seconds
Start the TV
Play the same video file… black screen and HDMI message on TV
Start to play a movie (mkv) with external remote, because screen isn’t working :-). It plays so I am able to upload the logfile.

The first file is a recording with dvdlink
The second is a mkv movie


I’ve just found this thread, and I’m wondering if it’s the same issue as I’ve been experiencing.

I created a new thread earlier today (not knowing this one existed):

Notably the first time I had the issue was before the October update, but after installing a test build which includes various fixes which were incorporated into the October release.

Just wondering if this issue is solved with next update?
Workaround is to boot the 4K+ everything we switched of the TV, but hope it will be solved :slight_smile:

Experiencing the exact same issue. When TV is shutdown, Vero4K will need to be restarted/powercycled to get signal again. Highly annoying issue when the holidays are around the corner. Is there a workaround to this or a hotfix to revert the changes causing this? Thank in advance.

This should be fixed shortly.

Great. Thank you!

Thanks for your hard work!