Sometimes no HD sound

Unfortunately that’s not a debug log, but just a normal log. I can see you turned on debug logging at the end of the log (before uploading it). After turning that on you have to reboot, perform the actions you want us to see and then upload the logs… Could you maybe repeat that, please?

Yeah that’s what I did. I’ve done it again


1 Like

Sorry, my bad! All is fine… Thx

We’ll keep this in mind and will get back to you when there’s progress.

Could you see anything wrong from those logs?

No. Thanks for posting - finding this very difficult to nail down.

Is there nothing different between a failed attempt and a succesful attempt in the logs?

ALSA picks a sink by trial and error. If it fails to open a sink, it tries again with different parameters. If that fails, it tries a different sink until it finds one that it can talk to or gives up.

We are currently testing the changes to passthrough that went into the March update but got pulled out again as some people had issues. You can test by updating from the staging repo as described in the link I gave above. Some people have no trouble with High-res audio with that, others do have issues. It may be receiver-specific or perhaps depends on the associated video stream. So if you could test and report mediainfo and post debug logs that would be useful.

Just to be clear - the testing in the link is for multichannel pcm right? I actually havent tested that alot with the current version since I like to see on the reciever what audio im getting.

I can absolutely test, but i need to know how to test it. Putting it in fixed and see if im getting sound or no sound is that it?
And should i turn on debug and then test alot of material or just the same one over and over and then stop the debug and upload it?

Also…how do I change back if this screwes things up? :slight_smile:

The staging repository (stretch-devel) has the latest versions of all the OSMC packages for testing purposes. The instructions for using it are always the same so not special for multichannel PCM.

At the moment, the only major changes are in the kernel. You can revert those by going
sudo apt-get install --reinstall vero364-image-3.14.29-69-osmc and removing the line from your sources.list that includes stretch-devel.

The changes we made for multichannel PCM seem to work OK but may have produced a side-effect on passthrough. So it’s passthrough that needs testing now. Put your settings to Passthrough and Best Match and just see if formats like DD, DD+, TrueHD, Atmos (if your AVR handles it), DTS, DTS-HD (HRA, MA, X) play properly and are properly indicated on your AVR.

There are some further tweaks going in as we speak so please wait until 9-ish BST before upgrading. You should get kernel 3.14.29-74 (I think). Check it with uname -a.


Just a silly question - is there a place with test-files? I have most of the formats but not all, definately not DTS:X

There are a few. Look on the kodi and ffmpeg websites.

Those should cover every format out there. If there’s one missing, just send me a PM :+1:t2:

thanks for the results. That new kernel I said was being made has only now hit the repository. When you have time, could you do another upgrade from stretch-devel and test again?

You can post the results here as we are on a diferent theme from multi-channel audio, now.

3.14.29-74 (the same as the auto-update?)

7.1, Best match, Passthrough to a Yamaha 3060

5/5 DD+
3/5 True HD
1/5 Atmos
2/5 DTS:X

No distortions either on working or nonworking. (pretty massively good sound tbh when its working lol).

Atmos displays “True-HD” in the display when it does not work and there are no sound, also the speaker icons are gone. When working all speakres are lit and it displays “Atmos”.
On other formats it displays “Decoder off” when its not working.

Seems like we have a follow the sun testing group here 8)

1 Like

Any update on this?

Are there issues in general with sound from the Vero at the moment. I’ve had mine on Fixed and now and then I get a loud screech when starting a movie. A Vero reboot solves it.

The latest kernel in staging (stretch-devel) seems to do passthrough as it should.


Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.