Sometimes no HD sound

Sometimes when I play my blu-ray rips i’m getting no sound, if I go to the sound option whilst playing and change to a non-HD format it plays fine. If I stop the movie and start it again sometimes it will work, sometimes not.

My sound settings are set to 7.1 with ‘best match’ option, pass through enabled and all formats ticked. The Vero is connected directly to a Yamaha YSP-2700 and when working it shows DTS-HD or TrueHD on the the Yamaha display.

This seemed to start with the last release. Anybody else had this issue?

Here’s a debug log

Yes, same here. On kernel 69 (unless it updated) and connected to Denon S930H. Sometimes I have to start/stop the movie several times to get sound. Also notice I don’t always get sounds when browsing the menu so I’ve been moving around in the menus until I start to get the audible clicks then I’ll go start the movie. If I get no menu clicks and start a movie I usually have no sound. Haven’t had time to debug/log yet. Usually takes moving around in the menus anywhere from 5 to 10 key presses before I start getting clicks. I thought there was an option to pass some kind of low volume tone to the Receiver to keep it from “going asleep”…I need to try that.

I’ve set the sound to Fixed for now, this seems to turn off passthrough options and shows PCM on the Yamaha. Does that mean the Vero is decoding it?

The top option on the sound page, does anyone know what that should be set to, PCM (default) or HDMI ?

HDMI, set to optimized speaker configuration and number of channels is the maximum number of channels your receiver supports usually, even if not all speakers connected.

Then your receiver does all the sound processing from the digital signal it receives. That’s the setup most people want. If you require something different then you would know :slight_smile:

The best match/optimized/best match options are confusingly named.

And yeah PCM means that a receiver received decoded audio streams per channel and does not do the decoding itself. Of course that will still happen if you send an audio stream that a receiver cannot decode (e.g. multichannel FLAC).

Edit: Fixed suggesting “fixed” instead of “optimized” in regards the the initial problem.


I’ve read other comments suggesting Fixed is best but when setting Fixed it removes all pass through options. Is that right or a bug?


So what are the correct option for pass through?

Sorry typo, I meant you should set to “Optimized” in your case as you want passthrough all the way without Kodi constantly reinitializing the audio subsystem. Will edit the post.

Let me explain the modes quickly:

Best Match: Kodi takes a look at the audio file and sends the output as close as possible to what Kodi got as a response your AVR supports. This is hit or miss because Kodi reinitialized its audio subsystem. This causes audio drop outs frequently as AVRs are usually not handle this very well - especially when told to switch to the same mode again. In theory the “best” mode, but the implementation in Kodi is problematic for many people.

Optimized: You can configure some of the supported output options, e.g. what the receiver supports and how not supported stuff is handled. This is usually the setting most AVRs can deal without any issues. Kodi will stay in the same mode unless a different mode comes up (e.g. receiver stays in DTS until something else comes up). Basically only switched when needed.

Fixed: PCM mode, means Kodi decodes and resamples to output specs you configured. AVR still does processing as needed, just not the decoding (which is really no issue at all) of the channels. Most compatible naturally, though most people prefer decoding on the AVR.

In fact there is a very strong technical argument to have any media center decoding audio before it is sent to the receiver. But that’s a completely different topic.

Keep Audio Device Alive: Kodi is already ready so send audio at any time, so there will be no delay or missed audio. That depends on the box you are playing from. For the Vero that setting usually is of no consequence.

Send Low Volume Noise: Same thing above but this time for the receiver. So the receiver always gets a signal and does not need to switch modes. I personally use or I have problems with ARC (bug on my Sammy TV). So mileage may vary if needed or not.

Number of channels: Usually set as high as your AVR supports, so it can do DSPs based on the actual connected speakers. So configure to 7.1 even if you have 5.1 connected. You receiver does know what to do (e.g. downmix decoded DTS 7.1 to 5.1 connected speakers).

All “audio output” options only apply to what is decoded to PCM.

Just have to chime in here… Optimized is not at all the best option as it’s partly not working as expected and will sometimes even break things with PCM playback. Best match is always the preferred option: sending out whatever the source is without changing it (and resets after a finished playback to a no audio mode is definitely preferred, staying with the stream format used before NOT).

Optimized should be avoided for the time being!

Thanks. That makes sense.

I’ll try optimized although I think I had the same sound/No sound issue with that too. My other settings are to HDMI output device and 7.1.

Is it better for kodi to decode then, it seemed to work fine. The only downside is my receiver says pcm rather than truehd but I can get over that!

Best match didn’t work for me. It seems there are issues with pass through so I’ll stick to Fixed for now as that seems to work best for me.

On fixed my receiver shows pcm but kodi codecinfo shows truehd so I’m happy with that. Seems like it should be my receiver doing the hard work though and not the little Vero!

There’s still work done on audio atm…

A too bad then. Probably some other root cause then not related to the various modes when it comes to passthrough audio.

Guess some logs would be in order to see what the AVR adversatives and what the file actually is as well as some more detailed description of the the HDMI chain.

But as said Kodi decoding instead of your AVR shouldn’t really make a difference for you. Your AVR will still do it’s thing with the decoded audio stream.

And in regards to PCM audio (read music): One thing you definitely do not want to do is play it back at the original digital files sample rate blindly but instead what the DAC works best to prevent upsamling by the DAC before the signal is processed and while at if of course bypass any OS mixer.

But not going down the rabbit hole. Especially as neither the Vero 4K is an audiophile device nor is Kodi the right software here, but still only “Optimized” allows passthrough and specification of how to handle none passthrough formats. All’s I’m saying.

Anyway, if “Best Match” is the official standpoint for OSMC, then so be it and I stand corrected.

“Output properties are set at at the start of playback and will not change if the properties of the source change” is what it says on screen. For the life of me I can’t see why you would want this, especially if it applies to passthrough, which I think it does.

You might like to try this: [TESTING] Improved multi-channel PCM for Vero 4K

There have been changes for both PCM and passthrough.

Thanks. I don’t have time/patience messing with Linux stuff, been doing the pi3/beebox with librelec previously, I bought the Vero for an easy ride.

I’m happy with it set as Fixed, thanks for all the help

1 Like

We’ll get back to this… If you can live with this workaround for the time being, that’s good :slightly_smiling_face:

We’re working on audio and trying to squeeze the remaining bugs.

That part is about the re-initialization of the audio subsystem. The wording in the settings is misleading to what it is actually for.

For pass through it prevents an AVR from disengaging and engaging amplification stages (as it stays in the same mode) you know the clicking on better amp. That can cause dropped audio.

Imagine you play a season of a TV show in a row and all are in AC3. That should be treated like one stream without re-initializing the sound system as you would loose the first few seconds of audio of a file (well unless you delay) between episodes.

On one of my Amps, that I only use as a pre-amp for music these days (not using Kodi there) it was 5 seconds. It checked an analyzed data a bit before playing in simple terms. A bit like a handshake.

There is no real switching between modes with Kodi on many AVRs, it’s more of a “disconnect / reconnect” thingy. Though things have changed here a lot in the last 3-4 years with manufacturers and the firmware improved a lot as well as Kodi of course.

Yeah, calling it “Optimized” is plain stupid. That mode should be called “Expert” and combined with Fixed. It’s not optimized to playback but optimized to some user’s needs. So confusing. And “Best Match” should be called Auto (which can be hit or miss). Some streamlining is required for sure here to make it more user friendly and some refactoring as well.

Anyway, getting too off-topic here. As said I am just one of the few you really have a need for this mode for various reasons.

It’s very simple: if a next file has the same stream information/audio format, there won’t be a long gap with reset to no audio in between AFAIK (that could also depend on the receiving end of your audio chain - how fast it at changing modes, you might be correct). But there will be a gap and a reset once playback has ended or the format changes.
Kodi can pretty much mess things up, if you don’t reset properly - with optimized the audio stays e.g. at DTS when DTS was played until something new is played. So, instead of going to no stream or no audio, it’ll stay with DTS for as long as you don’t play anything. That’s not making much sense.

And what you’re referring to here: queued playback… Using optimized with queued playback will not work at all latest when formats change within a playlist. We’ve found during testing that Kodi sometimes produces an utter mess with this setting - exactly the opposite of what you described and expect of the setting :rofl:

So, honestly, normally best match should be the only logical option. Who has a DAC/AVR connected that can’t work with 16 to 24bit and 44.1 to 192kHz PCM? Most can work with all samplerates and bitdepth supporter by the Vero and passthrough options can be configured per format. :wink:

But there are still a few bugs left as this thread shows, but we’ll revisit this and see what has to be done to make things work as expected for everyone… I hope this answers the basic question of the available options for the moment (we’re also aware that they can be confusing) and we can leave it at that for the time being :+1:t2:

I posted logs on my 2nd post above. Not done them before so included everything. If you need another let me know.