Sometimes no sound on play


After the latest March update, sometimes when I play a file I get no sound. It’s not specific to the file and happens with significant frequency so it’s a bugger. The workaround is easy though: stop and play again. My sound setup is pretty standard: HDMI output, 2 speakers, no passthrough, no postprocessing, original volume, no boost on center channel and otherwise default settings. Adjust refresh rate and sync to display enabled.

First debug log, I play a file and I get no sound:
Second debug log, same file after stop and play, now with sound:

I see nothing of significance in the logs.


You probably don’t want Sync Playback to Display.

I suspect this issue is a duplicate of an issue @thansen_dk reported.
Does disabling Adjust Refresh Rate always give you audio?


I can reproduce with sync playback to display disabled. I cannot reproduce with both adjust refresh rate and sync playback to display disabled.

I don’t think you want Sync Playback to Display on.
That was a suggestion unrelated to your question.

I will investigate the issue with Adjust Refresh Rate.

Thanks for your time Sam.

Regarding Sync to display, my understanding was that it would adjust for the minimal difference between the 24Hz the TV is capable of, and the 23.98 fps of most source material. Now I never tried to disable it to check if it is something perceivable. I will follow your suggestion.


Your display should support 23.976Hz, a fractional video mode. Vero 4K will output at this mode provided that your TV supports it and Adjust Refresh Rate is enabled. If you don’t notice any judder, then it’s working as expected.

However – this isn’t causing the issue.

I’ll try and work on this tomorrow and Friday. For now, although it’s annoying, pressing stop and play again should resolve the situation.


Yup, no problem, take your time. Let me know if you need test.

After the April update, I still have this issue. Is there anything I can help you with to work it out?

1 Like

Still being worked on.


My workaround for this issue until it get fixed is when I start a video and the audio is missing, is simply just switch to normal TV and back again to HDMI input.
In the beginning I had “Adjust display refresh rate” set to off, but it drove me crazy that the video didn’t play smooth :slight_smile:

Do you still have this issue after May update? I’m asking because it is still a huge problem for me.

Thank you :slight_smile:

Issue still there for me :frowning:


Let us know what you need from us to get this issue resolved.



I was able to replicate this on a TV for a couple of days, but then when I went to investigate the issue, I found that it had gone away.

I think that when the refresh rate is changing, the receiver is not reporting the full audio capabilities because the EDID is not read quickly enough.

To confirm this, what we can do is check what’s advertised when things do work and what’s advertised when they don’t. I suspect however we might find that this is a bit racey.

root@osmc:/home/osmc# cat /sys/class/amhdmitx/amhdmitx0/aud_cap 
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48/88.2/96/176.4/192 kHz, 16/20/24 bit
PCM, 6 ch, 32/44.1/48/88.2/96/176.4/192 kHz, 16/20/24 bit
PCM, 8 ch, 32/44.1/48/88.2/96/176.4/192 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz, 16/24 bit
DTS, 6 ch, 32/44.1/48/88.2/96 kHz,  bit
Dobly_Digital+, 8 ch, 44.1/48 kHz,  bit
MAT, 8 ch, 48/96/192 kHz,  bit
DTS-HD, 8 ch, 44.1/48/88.2/96/176.4/192 kHz, 16 bit

@thansen_dk Does this change when you get a video that doesn’t play back corrrectly?


Hi Sam

Thank you for helping me out :slight_smile:

No it does not change, always shows the same regardless if there is audio or not.

osmc@osmc-stue:~$ cat /sys/class/amhdmitx/amhdmitx0/aud_cap
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48 kHz, 16 bit

I think you are right about that.
If I start a video and the audio is missing, I can get the audio back by changing to another source on the TV and back again, this always works.


I get the same output as @thansen_dk and also don’t notice any changes.

Just for info.

Bought a new high quality triple shielded HDMI cable, it made no difference at all.



Any news about this issue?

Hi @thansen_dk

Yes. A few users experienced this problem and we found out that it was indeed related to the wrong audio settings in Kodi.

I had the same issue on a TV I was testing some clips on until I adjusted the Audio Settings. Since then, I haven’t been able to replicate it.

Can you take a photo of the audio settings in Expert Mode?

Also worth mentioning that there are some audio improvements coming in the June update. There’s a fix for occasional pops and a couple of other things.


Hi Sam

Sorry but I really don’t think that this is a settings problem. I have had the problem from the start (4 month) and out of desperation I have tried all possible setting and combination of, but I could of course be wrong (hope so)

It is not some specific files that have no audio, it is all that sometimes have no audio. If I for an example start playing the same video 10 time in a row, then the audio will be missing 3-5 times.

I can the audio back if I change the source briefly on the TV.

Here are my current audio settings.