Sound mode always defaults to 'Multi Channel In' instead of e.g., Atmos

I have a Vero 4K+ running the latest OS connected to a Denon AVR and I have noticed that for some time, the sound mode of anything I play via the Vero is either Stereo (mostly navigating the UI) or Multi Channel In ( in the AVR manual this refers to multi-channel PCM/DSD sources). I have played a few Atmos demo files, for example, but the sound mode reverts to Multi Channel In. The sound mode can be upscaled via the AVR remote, however the sound mode selection used to be automatic when playing something via the Vero.

I don’t set aside the possibility that cause of the issue could be on the AVR but I did play a Bluray disc via my Sony BD player and once selected Atmos for sound mode in the disc, the AVR displays the sound mode as Atmos.


  • Vero 4K+ running latest February update
  • Denon AVC-X3700
  • LG CX

Link to the Vero log:

The files names I used for the Atmos sound mode test. The demolandia files can be downloaded via the links:

This is not related with the sound mode issue mentioned above and I can create a separate topic for this but on my search for demo files to test this issue, I found a website with a few trailers, which I tried to play ( see log) but the Vero would only play audio and not video. Could this be an encoding issue?

Trailer files played:

Thank you in advance!

Did you check your audio passthrough settings, in particular have you enabled ‘passthrough’ so that your AVR does the decoding rather than your Vero/Kodi ? The AVR is probably reporting ‘Multi Channel In’ about the stream from the Vero as it detects the result of Kodi’s transcode to multi-channel PCM.

For more detail on how different audio streams are handled and appropriate setup see here Audio Setup.

1 Like

Apparently not:

Dolby Digital (AC3) capable receiver: true
Enable Dolby Digital (AC3) transcoding: false
Audio output device: ALSA:default
Number of channels: 7.1 ===> Default: 2.0
Output configuration: Best match
DTS-HD capable receiver: true
DTS capable receiver: true
Dolby Digital Plus (E-AC3) capable receiver: true
Play GUI sounds: Only when playback stopped
Allow passthrough: false   ***********************************
TrueHD capable receiver: true
Adjust display refresh rate: On start / stop ===> Default: Off
Sync playback to display: false
1 Like

That was the solution. I don’t remember disabling it or even going back to this section of the settings after configuring quite a long time ago. Anyway, the sound mode is now switching accordingly to the source. Thank you for your help!

Regarding the trailers only playing audio, would you have any guess? I played the files on my Macbook/VLC from the same location and audio and video play without any issues but that device has a lot more hardware capabilities. My LG TV, like the Vero, only plays audio. Perhaps the hardware is the limitation here.

1 Like

Check the mediainfo of the file after downloading and share here

I already shared on the original post. The second link seems to not respond to clicks but selecting and opening in a new tab works.

OK, overlooked.
I think this combination not supported by @grahamh can comment

Chroma subsampling                       : 4:4:4
Bit depth                                : 10 bits

Correct. Vero can’t play 444 10-bit streams.

I see. I thought that would be the case. Thank you all again for your help and time.