Sound of films is full of crackles (Analog 3.5mm)

Hello everyone !

I upgrade my Leila Build on RP3 with Matrix and I got aproblem :

I was no more able to choose HDMI + Analog (3,5mm).
I need to add dtoverlay=pisound and dtparam=audio=on in the txt co fig file.
Now I can choose bcm2835 Headphones and it works fine to listen musique (MP3 I presume) but the sound is horrible when I watch video (my mkv hollidays movies), I hear some crackles.

I tried to install alsa-utils and the volume is very low (I must increase the volume on osmc at 100% and my amp at the maximum) AND the crackles are always audible.

Here my logs :

Any solution ?


I’m not the only one to have the same issue, can somone help us ?


1 Like

I’ve been trying to reproduce this - sometimes it’s there, sometimes not. I thought it was just DD/DTS streams but some DD audio plays fine. Can we narrow down what sort of audio causes this?

For me I see the problem with all DD/DTS streams. Anything digitally encoded. I do not see it with AAC streams. I am playing through a 3.5mm jack into an stereo amplifier without DD decoding so the RPi is doing all that work I guess.

Yes, that’s what I found when I first tested but some DD tracks were playing OK yesterday. Are you fully up to date?

Yes I am. However, it could be my choice of media I guess. I’ve tested with ripped DVD/BDs (Handbrake) where I’ve kept the main track (stored on a shared library using SMB share). Those vary from much older DVDs to newer ones with Atmos etc… All crackle. The only ones that do not crackle are much older rips where I’ve ripped to stereo AAC.
Also playing TV channels through TVheadend and the TVH plugin, where most channels have a DD channel crackle.

just some info from the other thread…
mp3, flac and avi files are ok
mkv (most with 5.1 sound) files have crackles.
Can it be 48000 vs 44100Hz?

Broadcast TV? No Dolby audio here in UK - AAC 5.1 crackles. AAC 2.0 doesn’t.

I can get crackles on both.

I’m in the UK, but use DVB-S2 with multiple dishes/LNBs. I do not know about DVB-T, but many satellite channels use AC3/DD for sound. For example BBC News HD has DD with 2 channels.

1 Like

Did a bit more investigating…
Flac, internet radio, system sounds are fine.
I have found video files that work and don’t, all being encoded with AAC LC. The only difference is the bitrate.
The video with 89.1kb/s bitrate plays fine, while videos with 144kb/s and 224 kb/s have crackles.
Perhaps it is a matter of insufficient resources to properly decode the audio?

I have the very same problem with Pi3B+. I’m upgraded from previous version, and then the 3.5" jack audio stopped working. I added dtoverlay=pisound and dtparam=audio=on to the config file. Now the output has sound, but it is very cracky with almost all files. If I turn off hw acceleration, then the sound is good, bud the video stutters. I tried all combination of hw acceleration and framerate sync options, and none of them working.
After all of that I installed a fresh version, but the problem still exist with the new install.

1 Like

Hi. I had the same issue when upgrading to the new OSMC version with Kodi 19. Done some research and came across this post:

This is regarding a Raspberry Pi 4 while I have 3B+, but the issue seems to be similar so I tried to add audio_pwm_mode=1 to the config-user.txt and rebooted.

And it seems to be working. I haven’t tested a lot of files, but at least the Youtube videos I know has issues before is now working. In the referring post, changing this mode to 1 results in a loud hissing sound, but I haven’t noticed that, so for me it seems to be working.


Adding that worked to remove crackling noises for me. …and after adding it I now remember doing the exact same thing years ago! :slight_smile: Well discovered!

I do get a lot of hiss though. RPi analogue audio was never supposed to be HiFi, but I believe it’s been improved for Pi4.

EDIT : after trying again to watch some movies the blowing sound is always there…

(I try to add audio_pwm_mode=1 in the config-user.txt file and the sound was awful, like someone or the wind was blowing air in a mic.

I first unistall alsa-utils package (after the install of the package, the volume was very low) and nothing happend (the volume was just higher).
I try to change audio_pwm_mode=1 to audio_pwm_mode=0 and I was no able to choose bcm2835 in the audio menu, it disapear and the sound was going out by the HDMI on my TV.
I change audio_pwm_mode=0 in audio_pwm_mode=2 and audio_pwm_mode=3 nothing change. (with a reboot each time)

I was surprise, the dtparam=audio=on line was missing (I haven’t remove it :thinking:)
I have decided to add dtparam=audio=on again, and change audio_pwm_mode=3 to 1 again.
FINALLY, after a reboot, the sound is going out my analog amp and his speakers AND there is no more crackles or blowing sound at all AND the volume is correct.

However I miss the old options in the audio menu (HDMI ; Analog ; HDMI + Analog) :cry:
The sound was very nice and I was able to have the sound on my two devices (TV and amp). I was manually muting TV or amp when I was watching my movies on TV or with home cinema set (projector + stereo analog amp).

Thank you for your answers, I hope there will be some update to clean up this mess.)

1 Like

I’ve got this crackling issue on films only and audio_pwm_mode=1 makes it worse not better. Any other things I can try?

I haven’t found any solution, the problem is still there.