Sound option highlight for stereo downmix

Hi,

My current system is composed by an RPI3 connected by HDMI to my TV, the TV connected by SPDIF to a stereo receiver with floor standing speaker. These speakers are heavy bass capable even at low frequency (not as a subwoofer but still) but I feel the output from OSMC flat. Checking the option:

  • include LFE in stereo downmix: even at 100% I cannot really feel the difference and an AVI surround test file with LFE does not output anything when LFE is played. Anything I need to new except just raise the rate to 100% for this option? (or bug possible?). It seems the perfect option for my setup.

  • Passthrough: “tvservice -a” shows a TV fully compatible with AC3,DTS, etc. but is it at any level interesting to enable it? I guess if used the other settings are meaningless (“include LFE”, boost central, etc. ).

  • resample: by default on medium, when does it apply? I’m not able to spot the difference between high and medium in a (too) short test.

Thx!

It seems you have a fully stereo system, so you should set Kodi audio output to 2.0.

I think this only works when you have a multi-channel input and set your audio output to 2.0. It will have no effect on stereo material as there will be no LFE channel.

It’s probably better to let Kodi decode these formats. Then you should get the benefit of the LFE control. Having said that, if DTS or AC3 are supported by your amp, the amp may have settings by which you can enhance the bass.

It applies only when you have material which has a samplerate that the receiver/TV cannot handle.

I understand it the other way around but may be wrong of course. A downmix = reducing the number of channel AFAIK so if this is true it should include the LFR channel on L/R stereo channel.

Not much on the amp side but I will try both option on a longer period, thx :);

I think we are saying the same thing. If you set Kodi to 2.0, you get this for stereo:

FL <- FL
FR <- FR

and for 5.1:

FL <- FL + aBL + bFC + (optional) cLFE
FR <- FR + aBR + bFC + (optional) cLFE

But if you set kodi to 5.1 and you only have a stereo amp, all of BL, BR, FC and LFE are ‘thrown away’. I may be wrong, @DBMandrake is the expert.

You could also try AC-3 transcoding. That will send Dolby Digital to your TV without any LFE enhancement but your TV may make a ‘better’ job of downmixing to your amp.

Interesting point! The “include LFE” may not make any difference if this is the way it works you’re right. I’ll try to make a test (2.1/5.1 speaker setup) and maybe DBMandrake may have some highlight too.

I tried the passthrough option (all enabled) and it works but I’m not able to hear the difference in the way I’m looking for at least. It may remove from the RPI some load but at this time it’s not noticeable (further consideration so)

thx!

[Update]

With the June update I get finally a consistent result:
Output speakers set to 2.0
“include LFE in stereo downmix” enabled
LFE volume sets to 80%
Passthrough disabled

I’m able to add extra bass to the stereo amplifier output. I downloaded surround test files and even if not all of them reproduce the LFE channel (maybe the file itself) official test files (Dolby etc.) do. Same with the test movie I used.

I ran the April update at the beginning and had some issue (no LFE) but it seems solved with the June update.