Sound out of sync when playing video

Since yesterday the sound has been sometimes out of sync when playing video-files on my Raspberry Pi 3. I haven’t made any changes that i know of. I updated OSMC today to the latest version (2018.02-1) but the problem still exists.

I have the TV connected via HDMI to my Raspberry and the speakers are pretty cheap running from the TV via 3,5mm jack. No giant soundsystem or pre-amps or anything like that. Never had this problem before.

Not all videos are out of sync and sometimes they suddenly are in sync again when playing them. The video also freezes sometimes but the audio keeps playing, the video “catches” up in about 5-10 seconds and goes back to “normal” with the audio out of synd like before.

When trying to correct the audio i have to adjust it about 250-900 ms to get it about right. Different videos are out of sync different amounts. No “always 250 ms off” or anything like that.

Anyone get an idea where to start looking to fix this problem?

I have looked around the forum, asked the almighty google and checked in the settings but nothing i’ve tried have solved the problem.

You are not specificied nothings…

Nothings like what type of video you tryed to watch ? X264… xvid… mpeg2… or what’s else ?

Nothings like how you tryed to watch this video ? IT’s a network streaming ? IT’s a usb device ? Or what’s else ?

Nothings… we are not magician…

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

.mkv files are the ones with the problem. Haven’t tried a lot of other video-types but will try a bunch others this evening.

I’m running the videos from a USB3-harddrive directly connected to the Raspberry. No network streaming.

Yes, totally understandable. Will do that as soon as i can.

Yeah… the usb3 device have a standalone power adaptor ?

If you want you can also provide some mediainfo of some mkv you can obtain this issue…

About my fist reply… i hope that you understand my irony :slight_smile:

Yes, standalone power adapter for the harddrive.

Will look into that. Just weird that it started yesterday without any changes made in settings or new update. Also it’s files i’ve watched previously without any issues…

@FaustoGSR What mediainfo should i look for in the .mkv files?

The link that Sam provided above explains how to obtain mediainfo.

Thanks. Missed that part in the link in Sam’s post.


Just to be clear, this video-file has played with no issues before, several times and yesterday it started to have issues.

Do you think that your problem might be similar to this one: Playback Video - sound stuttering after March 5th Update

Yes, and that’s where I’ll be following up

You can try enabling OMX player for now until there is a fix.

I have take a look on mediainfo… apparently nothigs strange… for example:
Format profile : High@L4.1

The profile L.4.1 i thinks it’s the top profile supported by the recent hardware… upper than this it’s problably obtain problems during reproduction.
For all my personal enconding i ever using Hight@L3.1… best for compability also on old hardware standalone player.

I have also compared this mediainfo whit some file i have already watched on my Pi2 setup… in addition to the profile thing i don’t see nothigs “strange” can create serious trouble during reproduction of this file…