Sparkles on Screen, No Wi-Fi Option, Doesn't Reboot, Can't Detect USB Drive

Hi. I’m having problem with a Vero 4K+. Started with 2019.05-1 firmware, just finished the initial set up and restarted the Vero. After rebooting I get sparkles on the screen.

Then I checked out the network module and found there’s no Wi-Fi option

I tried installing a fresh copy of Vero 4K+ 2020.01-1 and install was successful. But after going through initial set-up again, same problems.

I tried rebooting and saw this on the screen. And it would freeze. I had to unplug it and plug it back in.

I tried to run logs first and hope I can copy to flash drive and I found out that my flash drive can’t be detected. Which is weird because I used the same USB slot to install a fresh copy of OSMC. The remote is working and it’s plugged into the usb slot. Weird right?

I was able to find a LAN cable and uploaded the logs. Here you go

Is this already a hardware fault? Thank you.

I tried switching the USB drive and the remote dongle and the Vero 4k+ still cannot detect the usb drive. Also tried the usb drive on an older Vero 4k and it got detected.

Sparkles usually mean a bad HDMI cable or too long a length. I would try solve that first.

The USB drives aren’t working because UDisks is not starting as per your screenshot. A reinstall would solve that.

I’ll look for a replacement cable and reinstall. Thanks.

  1. Used a shorter (2ft) HDMI cable, same issue. But I found out when I gently press the hdmi socket inward, the sparkles go away.
  2. Reinstalled OSMC image and it fixed the USB problem.
  3. Unfortunately, Wi-Fi problem persists. Much like this one

Try clean the HDMI with isopropyl alcohol
WiFi is hard to speculate without a log. The unit might need to be returned back to us

I logged in via SSH (via ethernet). These are the steps I did after.

  1. Did connmanctl technologies, wifi seems to be powered on but not connected
  2. Did connmanctl enable wifi, wifi is already on
  3. Did connmanctl scan wifi, says no carrier
  4. Did grab-logs -A, this is the log

I turned on logging the normal way, tried connecting to a wifi ssid and waited for it to fail.
Here’s another log. Hope it’s useful

Wait: so are you saying you can see WiFi networks?
Your log shows that the WiFi chip is working correctly.

Yes. After reinstalling osmc can now see Wi-Fi networks. But when I try to connect it takes about a few minutes and then will fail.

Have you tried connecting via connman instead of My OSMC?
The log seems to suggest some authentication error.

Not yet. Because connmanctl scan wifi gives the error ‘no carrier’

Do you have My OSMC open in the background?
Try stopping Kodi, then disable WiFi via the command line, then reboot and re-enable.

Will try. Thanks!

So it would go something like this?
sudo systemctl stop media center
sudo connmanctl disable wifi
sudo reboot now
sudo connmanctl enable wifi


Remember you need to run connmanctl agent on in your session to connect.

Ok. Thanks

Were both cables the same brand. I have some BlueRigger brand cables that work great with the exception of the hdmi port on the front of my AVR because that jack is inset a bit, and these cables are overmolded a little bit too much making their connection just a bit shorter than normal.

Hi @darwindesign. Cables are different brands.


  1. Your solution worked for the wi-fi. it’s now connected. I tried testing the wifi by using youtube add on but it freezes whenever I try opening it. It freezes up to a point where I can’t ssh in.
  2. I cleaned the HDMI contacts but looks like the sparkles on the screen are still present.

Should I open another ticket for the youtube issue?