Vero 4K+ Does Not Detect Wi-Fi SSIDs

Did you install updates?
It may be easier for you to reinstall OSMC

Sam

Already reinstalled osmc from usb 2019.11-1 twice

Not sure then – it might be worth sending it back to us then.
I’d try and connect manually via the command line using connmanctl first.

This system hasn’t ever had 4.9 installed on it, right?

No 4.9 has been installed. Any articles on how to use connman?

So it worked before?

See Could not connect to Wi-Fi - #16 by DBMandrake

As mentioned before in the test thread, 4.9 is pretty much a one way street, and it’s not going to work properly if you try and downgrade.

Sorry for misunderstanding. I meant no. I haven’t upgraded to 4.9 on this unit.

Okay. I’d try a cold boot and the connmanctl approach. You could create a WiFi hotspot on your phone, verify your other devices can see it, then see if the device sees it.

Ok thanks

Created a hotspot on my phone. Then unplugged Vero, plugged it back in. Attached a keyboard and selected power → exit to enter command prompt. Then this is what I typed and responses

You haven’t run connmanctl scan wifi, so services being blank is not surprising.

My bad. Same steps taken now. Cold boot. Sign in command line. Error showed up

connmanctl enable wifi
connmanctl scan wifi

wifi not WiFi.

Says already enabled. Then no carrier.

No carrier is what you’d normally see if the wifi is disabled.

The WiFi module might be defective. You can send it back to us

Sam

1 Like

Thanks, Sam!

Hi Sam, just received my Vero and I’m encountering the very same problem:

Edit: Looks like a defective unit - I’ve connected an old usb network card and now can see the wifi networks.

Check this out

Had a similar problem with a just received Vero 4K+ too.

The solution is to install an image for the wifi fix. See the thread below.

@alphaque @fzinken many thanks guys! the newer image did help.
Cheers! :slight_smile:

1 Like