Spectrum Visualisation gone - [SOLVED] :D

I miss the spectrum vis while playing mp3s now I’m on Krypton. Can anyone suggest a similar one I can d/l?

Hi, it is still there. It is just disabled as a third party add on.
You’ll need to re-enable the popcorn mix repository and then reinstall Spectrum.

Thanks. That worked.

Hi Skeeter,
I’ve just enabled the popcornmix repository but there is no Spectrum visualization in it, only the Shadertoy.

What I’m doing wrong?

I guess it is no longer supported. However if you use the manual copy method as detailed here:

then it will work.

Hi, sorry about that. I’ve got three machines KODI here, two Pis with OSMC and a windows 10 machine with KODI and it is my windows machine that has still got Spectrum on it.
On the Pis I’m using Shadertoy, no Spectrum.
As an added note, on the Windows machine I’ve also got Milkdrop 2 and use it, comes closest to WinAmp. Sure miss that program, but KODI on Windows is a good alternative.
Once again, sorry about that. No Spectrum on Pis with OSMC.

I still use Winamp on Windows 10. Are you missing the installer? Oh and I’m also still using Spectrum on OSMC on the Pi.

That’s great. Perhaps you could explain how to get that into Krypton 17.1 on OSMC .
As to Winamp Pro, Well yes one could visit the dark side of the Internet and obtain a copy with serial number, but doing fine with KODI… The size on Windows is a little large and can’t burn play lists to a cd. But hey this is an OSMC forum so enough.

Well how I did it was first enabling the Popcornmix repository, as you yourself explained further up the thread. Of course then you find that the Spectrum & Waveform visualisations no longer seem to exist in the repository. But if you copy the original files back into their original places and then reboot the Pi, they then appear in your Add-on browser (under All) and you can enable them.

At least that’s how I did it. If you go to the thread “Kodi 16.0 - No Audio visualizaton available” that I linked above, then follow my posts through that thread, you should be able to sort it. In one of my posts I have put a link to a zip archive that contains the visualisation files.

Yes this is an OSMC forum so I’ll shut up about the Winamp (except to say that I use the ordinary, not the pro).

Thanks Mate.
That’s seems straight forward.
Have a nice weekend.

Well here we are, new year and all, and the OpenGL Spectrum no longer works. I get an error message about being unable to load libraries. The odd thing is that it both worked a week ago at least, and it has stopped working on all my Pis running OSMC.

I’ll investigate further in a bit, but has anyone else noticed this?

I set the screensaver to 1 min, then played music and waited. The message “Add-on couldn’t be loaded. Couldn’t load shared library.” appears.

logs: https://paste.osmc.tv/uxocidazek

Download working copy of the spectrum visualization here. Works on my pi with krypton

visit www.techworked.com for more info

It would be best to remove the additional link you have provided here. Such a script which you have directly linked here (insinuating that it might be useful), will almost certainly break an OSMC installation.