Speed problem with fstab mounted NFS

I’m running OSMC on a Raspi 2B and am also having trouble – NFS v3 mounted over ethernet via fstab.

Since the last update I can’t list files/play anything. Sometimes I can list folder contents in Videos->Files-{foldername} and subsequently play a video but it will crash the system altogether after a few seconds. Other times, the system will crash upon viewing the contents of folder.

When the video does play, the audio will cut out and the video will continue to play for a few seconds before a full system hang occurs. Have tried reflashing w/a fresh image and tried a few variations of mount options(will post back here this evening with the variations I’ve tried).

Logs and iperf3 please!

1 Like

I will run iperf3 this evening, but here’s some log-pasta from yesterday – fresh install of
OSMC_TGT_rbp2_20180109.img.gz with my previous fstab line and a direct copy of my sources.xml nodes (but no addons installed, just added as repo locations): https://paste.osmc.tv/fevuvayaqo

running a DLink DNS-321 NAS (old timey, runs on steam & lofty wishes) :steam_locomotive:

  1. Remove all the banned addons from your sources.xml
  2. I don’t see any attempt to play anything in your logs.

I split this into a new topic as the original poster was talking about an NFS server and you are talking about an NFS client.

thanks @bmillham

I’ll provide a log dump this evening after another fresh install and with no addon repos whatsoever. Funny, that log (above) is from firing up osmc, picking a known, good .mp4 and watching the system freeze, then rebooting and running grab-logs -A right away.

Once it hangs, I can’t access via SSH either, it’s a complete freeze.

Going to also try a few variations this evening: different/fewer mount options, Raspi 3, mount NFS over Wifi instead – all these worked before I ran the most recent update, hopefully I can help identify an edge case, though…

I am just putting a note here that with a Raspberry pi 3 and a fresh December OSMC, I am not able to find the NFS share (a QNAP server) anymore. It was OK with previous November version on a rpi 2. Unfortunately I do not have the logs yet and do not know when I might have time to play with it.

…neglected to enable logging on the fresh install :unamused:

here’s a log showing a video being played off my NAS: https://paste.osmc.tv/orasomuyew

and iperf3 shows some slowish throughput going from my desktop to the Pi(long cat6 eth) but as stated before, have had no issues until now: https://paste.osmc.tv/haziciyafu

You need to figure out your network issue. That horrible iperf3 performance, especially for wired! First thing to try would be a new cable.