Spinning wheel when trying to play movies

I am trying to play some various HD and 4K mkv movie clips from Sandisk USB 3.1 flash drive on Vero 4K+

On one unit they play fine. On another unit the movie will start but screen is dim and there is a spinning wheel for 15-20 seconds before I can see picture not dimmed. If I stop video and immediately try and play same video again it plays fine.

Here is log for unit not working

Unit that is working

Any ideas?

The only thing I was noticing was that the one with the issue isn’t connected to the internet and when you were starting playback the embuary helper add-on was trying and failing to get online information about the movie.

I need to be able to use this unit without internet.
I ended up reinstalling OS but still have issues. I connected ethernet and thought it started working but after about 5 clip or so it started acting sluggish and buffering very slow.

After reinstall no network and spinning wheel on first video played

Network connected then major buffering after 4th or 5th video clip

Rebooted and then same issue after 4 or 5 clips

Put same media flash drive in another Vero I have and don’t have any issues after playing several clips. Only difference that I can think is the USB media is not scanned into library of working unit.

Would that be on Moonfall because that looked like the thumb drive being slow…

2023-08-21 14:39:55.125 T:3168 debug <general>: Readrate 2461000 was too low with 11517040 required

Have you tried plugging the thumb drive into the other USB port?

1 Like

Well, the first “drive too slow” symptom occured

2023-08-21 14:52:12.169 T:3273     info <general>: CVideoPlayerAudio::Process - stream stalled

Unfortunately the system journal is incomplete as it is already ending at Aug 21 14:33:46. Also the apt history is empty.
However, this means that this device is not up to date with the software and at least a related patch is missing; I would reconnect the device to the network+internet and update it.

Please post logs of error behavior again but this time with updated osmc software so the kernel messages are complete.

After I did the clean install I ran the OSMC app to check for updates and it said there weren’t any other updates. Is there another way I’m supposed to get patches?

Sorry, I got confused since one of your system (the one with the issue) still shows persistent kernel logging being active although base-files-osmc 3.3.3 should deactivate this.

To get rid off the persistent kernel loggin, log in via ssh

cd /var/log
sudo rm -rf journal
sudo reboot

For the issue you have, I’ve currently no idea what could be the root cause. The logs indicates a too slow read rate from the device. In contrast is your statement that the same thumbdrive works fine on another Vero.

I will try to remove this. Can this kernel logging cause slowdown? Today I tried a different USB flash drive and experienced same issue.

It shouldn’t factor in.

Both USB ports have the same behavior? You said you did a clean install. Did you restore userdata from backup or set everything up again manually?