Splash Screen Freezes and Looks Garbled

Hi again. I’ve a problem with a Vero 4K+. It would start out normally, it turns off after a few seconds reaching the main menu. When I unplug and then plug it back in, it would look like this photo

I already tried changing power adapter, it didn’t fix the problem.

Does this still look like a software problem? Should I try reinstalling the Vero OS via USB?

There appears to be a kernel panic there. I would reinstall OSMC as the first step and make sure the device isn’t overheating.

Thanks @sam_nazarko. I’ll give it a shot.

I tried reinstalling OSMC. It turned off before the countdown ended. And when I plugged it back in, screen shows this

I will try again a few more times

2nd time, this happened.

Then froze.

Have you tried a different HDMI cable?

I will try. Thanks @bmillham

@bmillham got further. Installing files then froze and same screen

Oh well, it was worth a try. Does the screen look normal at first and then change to the garbled display?

Let’s see what @sam_nazarko has to say at this point.

That’s right. Looks normal then suddenly would look like that and freeze.

Since installation didn’t finish successfully I waited 10 minutes & turned it on to see what damage I’ve done.

This is what it looks like now. Then it would turn off within a minute (my estimate)

As you’ve raised a support ticket about this I’ll deal with it there.

Thanks, @sam_nazarko