Ssh access problem

Hi, I’ve installed the 2017.07-1 version, and can’t access with ssh.

If I try telnet to port 22, I see that a daemon is running:
SSH-2.0-OpenSSH_6.7p1 Debian-5+deb8u3

However, when trying with putty, I have an immediate “server closed connection”.

In the logs (

I’ve found:

Sep 30 11:37:05 osmc sshd[892]: fatal: no matching mac found: client hmac-sha1,hmac-sha1-96,hmac-md5 server,,,hmac-sha2-512,hmac-sha2-256, [preauth]

I’ve tried to uninstall ssh based on this,

but then I got an:

Sep 30 11:48:21 osmc mediacenter[340]: 2017-09-30 11:48:21.164558 exception value : E:Unable to parse package file /var/lib/apt/lists/ftp.debian.org_debian_dists_jessie_Release (1), E:Problem opening /var/lib/apt/lists/ftp.debian.org_debian_dists_jessie_contrib_binary-armhf_Packages, E:The package lists or status file could not be parsed or opened.

any clue?



If you’ve uninstall ssh, I would consider reinstalling OSMC.

Also their have been several issues with putty accessing ssh, these have been resolved by updating the putty client.

Thanks Tom.

If you’re trying to ssh wirelessly, this solved the problem for me:

I’d follow Tom’s advice of reinstalling OSMC though.

Hi -

I’ve reinstalled osmc which did not help - but updating putty from 0.6 to 0.7 did help and I can log in now - writing here in case anyone else faces the same issue.