SSH activated but no connection possible


As mouse and keyboard don’t work anymore by default in OSMC, I would like to install them.
But I wasn’t able to connect via SSH to my OSMC after a fresh install (an update killed my OSMC, I had to reinstall it).

So I went to my OSMC > Services > SSH and I was able to verify that SSH was running. Then I disabled then enabled it and tried again, but still nothing. I’d like to add that I can SSH to my other OSMC without any problem.

Looking up host “”
Connecting to port 22
We claim version: SSH-2.0-FuTTY_futty_0.63:044bd7c
Server version: SSH-2.0-OpenSSH_6.7p1 Debian-5+deb8u3
Using SSH protocol version 2
Network error: Software caused connection abort

No firewall, no router, no weird stuff.

Is support by default of mouse and keyboard planned for a future release?

Thanks for any reply.


You don’t say what you’re connecting from.

If you’re using PuTTY on Windows, make sure you’re on the latest version.

Edit: Ah, FuTTY. Try PuTTY.


Also just confirm ssh is running as osmc advises:

Attach a keyboard
Using the gui select power and exit.

If you hit the escape key (repeated hits, will possibly be required) you will be presented with a console prompt.
log in as the osmc user.

Check the output of:

systemctl status ssh

From the error message it does sound like you are using putty, as dil has already advised; please check it is the latest.

Thanks Tom.

Thanks for your replies.

FuTTY is fine (as said it works with my other OSMC with the same hardware), but even with the last PuTTY (32 and 64), I got the same problem.

Thanks for the ESC tip. Under the command line prompt my keyboard is working.

After checking SSH status, it seems that my SSH keys weren’t generated. All key files are here but they are 0 in size, that’s why systemctl status ssh returns key_load_public: invalid file

As my goal is to make my mouse and keyboard work again under OSMC, I installed usbutils and check if my mouse and keyboard were listed with lsusb.

Then I tried that as root:
usermod -a -G input,tty osmc

I rebooted OSMC but still no mouse and keyboard.

OK, I can SSH now after doing this as root:
rm /etc/ssh/ssh_host_*
dpkg-reconfigure openssh-server

Keys were regenerated and now I have to solve the mouse/keyboard problem.

Sorry I missed the fact that you already could connect to another OSMC box.

And were they? Don’t keep us in suspense! :wink: Are they wireless by any chance? If so, can you use a wired keyboard?

Now you can SSH, I’d suggest you post logs (grab-logs -A) if you want to take this further.

They are detected:
Bus 001 Device 005: ID 046e:550f Behavior Tech. Computer Corp.
Bus 001 Device 004: ID 046d:c01d Logitech, Inc. MX510 Optical Mouse

And they’re both wired devices and they work under Debian as I can type in the command line and after installing gpm, I can use the mouse too.
But they still do not work under OSMC.

Here is the log:


Well I assume you mean Kodi (as OSMC actually is the combination of Debian (OS) and Kodi (MC).

So could it be that you have created a keymap that is not working? Because if it is recognised as a normal keyboard it automatically would work.

Yes, I meant Kodi, sorry.

For the keymap, I don’t think so.
I surely tried to switch to an AZERTY keymap, but it was today, so long after I had the problem.

All I did during the fresh install was with the options given to me, so I don’t really see any way to do something wrong.

Anyway, a bad keymap shouldn’t have any consequence on the mouse.

Ok, suggest you enable debug logging. Reboot. Than press a few buttons like ESC, ‘s’ and then upload the logs.


I applied an update today and now mouse and keyboard are working again.
So that’s not really a solution found to the problem but at least it works now.

And thanks to everyone for your replies.