SSH connection: Password entry no longer possible


Yesterday I connected for the first time from my Win10 PC to the Vero 4k+. I used PowerShell. The first password entry worked without any problems. As recommended in the instructions, I then wanted to change the default password. When I was prompted to enter the desired new password, I suddenly could not enter anything. I tried again a few times but it didn’t work. I didn’t care and continued with the commands given to me by the tech support of the VPN provider and for which I was actually there. Unfortunately, after these inputs sent to me, the LAN connection on the Vero 4k+ did not work anymore and I could not get on the box via ssh either, because now the first password input did not work either. I can’t write a single character on the password line.
Since I had problems with the VPN lately anyway etc. I decided today to reinstall OSMC completely. I made myself a USB stick with the latest Vero 4k+ img and installed OSMC, worked wonderfully and the LAN connection now works again. But when I log in via PowerShell there is still the problem that no more input is possible once I was asked to enter the password.

Could someone explain to me why this problem occurred and how I can fix it? Thanks a lot!


When prompted to enter passwords on the command line in OSMC, as well as virtually all other Linux OS’s, you will not see any asterisk or other echo of your input. This is a security feature. You must simply type blindly when entering passwords.

Indeed. This is embarrassing now, I tried it umpteen times before :slight_smile: But when I had to enter the password for the first time, it was still visible with certainty ****. Whatever, thank you! Problem solved.