SSH from windows with putty to pi3 with osmc

running the latest verson of osmc (oct-2017, I believe) on pi3 on wifi. note: have two other pi3’s running rasbian that can ssh with putty from windows 10. Weird: can ssh from another unix box, including from a virtualbox debian on the same windows 10 box, but putty returns with “Network Error: software caused connection abort” It has not even come back to ask if I want to accept the key. Any ideas? Also osmc’s smb client can’t see my network fileservers.

Are you able to ping the pi using name and IP?

Yep! Can also ssh from debian in virtualbox on the same machine.

Check whether SSH is enabled under My OSMC -> Services.

Otherwise, upload some logs.

Why? I just said I CAN ssh from a unix machine or even the window 10 machine running virtualbox debian. Putty DOES work with two other pi3’s running raspian. Ergo: not the wifi adaptor, not router. Which logs do you suggest?

Here is the only funny I’ve found: Did service ssh status -l got this:
root@osmc:~# cat sshstatus.txt

  • ssh.service - OpenBSD Secure Shell server
    Loaded: loaded (/lib/systemd/system/ssh.service; enabled)
    Active: active (running) since Thu 2017-09-21 11:58:22 MST; 1h 10min ago
    Main PID: 315 (sshd)
    CGroup: /system.slice/ssh.service
    `-315 /usr/sbin/sshd -D

Sep 21 11:58:22 osmc systemd[1]: Started OpenBSD Secure Shell server.
Sep 21 11:58:22 osmc sshd[315]: Server listening on port 22.
Sep 21 11:58:22 osmc sshd[315]: Server listening on :: port 22.
Sep 21 12:57:07 osmc sshd[815]: fatal: no matching mac found: client hmac-sha1,hmac-sha1-96,hmac-md5 server,,,hmac-sha2-512,hmac-sha2-256, [preauth]

But if broke, why does it communicate fine with unix?

did apt-get update; apt-get install ssh and now the status is clean, still doesn’t talk to windows but still talks to unix.

From the evidence you give, it seems there’s something wrong with putty rather than OSMC. i would be looking to delete any keys you have on the Windows machine for that Pi and try again to connect.

Of course that is the wrong ssh…removed and checked ssh-app-osmc and apt-get says ok and newest. Status is clean after connecting to unix, but putty on windows gets the above error in the status. I am stumped on this…not a ssh guru, looks like it can’t negotiate auth?


Is their any chance of testing this with wired connection?

Also it may be worth reading this topic:

OP had a similar issue.

Thanks Tom.

fails over cable too. Where does windows putty keep the keys? Looked in registry…no luck

Are you running latest version of Putty?

Algorithms used by default can change as security improvements are made and older versions of Putty can struggle


If you’re talking about the host keys: HKEY_CURRENT_USER\Software\SimonTatham\PuTTY\SshHostKeys

(that’s what google says). :wink:

Edit: Can you show us the error log from Putty?


The ssh keys are located as dilthedog has pointed out.

Logging is disabled by default in putty, on the left hand side in putty you will see logging under Session. I would change this to All session output and try connecting again and provide the output as dilthedog has requested.

The log will located in the folder putty lives in, called putty.log.

Thanks Tom.

That was it. Found a new 64-bit version of putty and installed it. Works now. Thanks.

Congratulations! You’ve made me upgrade too, although I’ve all but given up using putty since I installed cygwin. Gives you a more unixy feel.

Found them when I looked to export the data before ugrading puttly.

Actually, removing putty then loading the new one wiped the keys and that was probably what fixed the problem… So Grahamh was probably the correct answer.

Well a very old version of putty could also have been the culprit due to missing encryption algorithm.

Went from .62 to .7 - 64 bit.