Ssh login no kex alg

I can’t login with remote ssh on my Vero:

root@NAS:~# ssh -v osmc@
OpenSSH_3.7.1p2, SSH protocols 1.5/2.0, OpenSSL 0.9.7e 25 Oct 2004
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file /root/.ssh/identity type -1
debug1: identity file /root/.ssh/id_rsa type -1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.7p1 Debian-3
debug1: match: OpenSSH_6.7p1 Debian-3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.7.1p2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-sha1 none
debug1: kex: client->server aes128-ctr hmac-sha1 none
no kex alg
debug1: Calling cleanup 0x236c4(0x0)

Any Idea ?

Have you tried ssh’ing from a different machine and/or using a different SSH client ?

For example on Windows try putty.

From a different source server I can login with SSH … mumble mumble…

@sam_nazarko only my putty client can connect to the ssh server of the Vero.
Other client exited: no matching algo kex

SOLVED adding :

KexAlgorithms diffie-hellman-group1-sha1

in OSMC:/etc/ssh/sshd_config (and restarting ssh)

Haha, this problem also plagued me a long time.
Many people suggest to modify parameters ciphers and KexAlgorithms in the file /etc/ssh/sshd_config
But in fact, due to the server security reinforcement, no longer support some ciphers and KexAlgorithms.
For example: diffie-hellman-group1-sha1 is widely used, but not security enough

If the older ssh client does not support these algorithms, an error occurs: no hex alg
For example: Sun_SSH_1.1
Quickly upgrade the client ssh!!
Good luck!

I know this thread is pretty old, but could you help me upgrading the ssh client on osmc??

I really need to be able to connect from a kodi outside my network to a kodi in my network (that has the local disk). I think this could help a lot of people how want to do the same.

Thanks for your help

I’m not sure how upgrading ssh resolves this. With proper port forwarding this shouldn’t be an issue.

ActionA, im fighting with this sftp conecction. I use the instruccions that PAEDRAE said:

ADD: KexAlgorithms diffie-hellman-group1-sha1 in OSMC:/etc/ssh/sshd_config (and restarting ssh)

And know this happens when I try to connect to the sftp disk,

13:55:06 T:1748 ERROR: SFTPSession: No authentication method successful
13:55:06 T:1748 ERROR: SFTPSession: Not connected, can’t list directory ‘media/’
13:55:06 T:8116 ERROR: XFILE::CDirectory::GetDirectory - Error getting s
13:55:06 T:8116 ERROR: CGUIDialogFileBrowser::GetDirectory(s failed

Of course I can connect to sftp through cyberduck, and to ssh through putty

Any idea?

Thanks for all

I had the same problem. And what solved the issue was upgrading the ssh client
You can download the binaries from windows here: OpenSSH Binaries Windows