Ssh not working

Hi guys,

I have a vero 4k that I cannot ssh into? i have multiple rpi’s that i can ssh into so its not because of a network problem or knowledge.

here are my logs

many thanks

You must have issues with your configuration files and therefore the removal (and new installation) of SSH APP is not working.

You need to first get a clean removal and then reinstall from App Store.

Log started: 2022-06-05  23:42:47
Removing ssh-app-osmc (1.2.4) ...
Removing 'diversion of /etc/ssh/sshd_config to /etc/ssh/sshd_config.distributed by ssh-app-osmc'
dpkg-divert: error: rename involves overwriting '/etc/ssh/sshd_config' with
  different file '/etc/ssh/sshd_config.distributed', not allowed
dpkg: error processing package ssh-app-osmc (--remove):
 installed ssh-app-osmc package post-removal script subprocess returned error exit status 2
Errors were encountered while processing:
Log ended: 2022-06-05  23:42:47

thanks, for some reason I have had issues with installing it on the app store. It sometimes it doesn’t download and sometimes it downloads but it doesn’t say it has been installed?

I just tried to reinstall it

Exact same issue I had, like I mentioned earlier … I will probably not be the only one.


From the console, can you please try:

sudo apt-get install --reinstall ssh-app-osmc

Thanks Tom.

Thanks Tom,

I did as instructed. Ssh is now showing that it is installed but I still can’t connect. I can ping the device and connect to my phone so I know it’s on the network. As I mentioned before I have other devices that I can ssh into, no probs.



From a client device connecting to the vero4k (if your on Windows, it may easier to run this from one of the rpi’s), could you please issue the following command:

ssh -v osmc@

Thanks Tom.

Hi Tom,

A fresh install of the previous version did the trick. It all worked straight away

1 Like