SSH setting reset after recent update [solved]

I solved my own issue but surprised that it hasn’t been reported (or I missed it when searching), so posting here for posterity.

When I first installed OSMC on my RPi2 (way-back alpha-4) I set-up a separate SSH account as I wanted to use the Pi also as a remote file server via public-private keys. Everything was working fine until a recent update, when I suddenly could not access over ssh. Not sure which update, as I haven’t logged-in an a while.

Anyway it caused some consternation because I was working remotely at the time and couldn’t access my files.

When I got home I found that my ssh setting had been reset to default, and I was getting uid errors when using sudo (/etc and /proc were now owned by OSMC, not root).

In short, I solved it by editing the sshd config file directly on the RPi, which had also now allowed root login again, and had removed me from ‘AllowedUsers’.

sudo nano /etc/ssh/sshd_config

I guess you might have not been on the october update. Since the october update config protect is ensured, means from now onwards during updates your config should be untouched

Ah thanks - that’s good to know! I haven’t been keeping-up with developments.

Cheers :smile: