SSH suddenly won't authenticate?

I have been using the same credentials for many months, and suddenly I get prompted that password is incorrect and to enter correct password when attempting to connect with SSH.

Using JuiceSSH on Android. User/Pass is saved as an identity and assigned to the correct connection. Identity was not changed since it was created, using default credentials - osmc:osmc.

Have since also tried pi:raspberry but no joy.

Pi is in remote location btw.

Really confused about this one. Any ideas?


So have you opened port 22 on the router so you can remotely SSH to the Pi?

Ah this may be the issue, although I have used this connection many times before without issue - so it is quite possibly open.

Would I still get a login prompt even though the port may not not open?

No. It generally won’t respond at all if the port is closed.

I’d guess that your Pi has been pwned and the password changed.

Leaving the default password is asking for trouble.

Well everything still works fine. Playback, FTP etc How else would I know?

I assume this means that someone else is running Kodi at the remote location.

If the device has been compromised – and leaving the default password unchanged on an Internet-facing device means that this is very likely – there’s no knowing what’s running on it now. It could be a DDOS bot or a bitcoin miner.

You could ask the end users to attach a USB keyboard, exit from Kodi and press escape when the splash screen appears. Then see if they can logon with osmc:osmc.

Don’t forget, more importantly, if the device has been hacked, there is now a rogue device inside the firewall at that location, who now has ability to directly reach every system on that local network! The entire network and every device on it is at risk of compromise!