Ssh to osmc

Hi

somehow I have blocked myself and can not logon from a certain computer to the osmc raspberry.
Working from others.

where can I check why this is not possible and re-enable it?

Thanks

I got his error:Failed password for osmc from 192.168.0.9 port 56386 ssh2

I used the standard password…?

How are you trying to access? software client? OS?

Connect a keyboard and try to login on the local console to ensure the password was not changed

Hi
still having this problem via juicy on andriod.

it is working on one RPI but not the other.

setup is same.

can logon to ssh via ubuntu always with key.

On juicy I am asked for the password but it is not accepted but it is the standard one and working via ubuntu ssh commandline.

Okt 22 10:04:26 OSMC94 sshd[15478]: Failed password for osmc from 192.168.0.28 port 57340 ssh2
Okt 22 10:04:26 OSMC94 sshd[15478]: error: Received disconnect from 192.168.0.28 port 57340:3: com.jcraft.jsch.JSchException: Auth cancel [preauth]
Okt 22 10:04:26 OSMC94 sshd[15478]: Disconnected from 192.168.0.28 port 57340 [preauth]
Okt 22 10:04:34 OSMC94 sshd[15480]: rexec line 19: Deprecated option KeyRegenerationInterval
Okt 22 10:04:34 OSMC94 sshd[15480]: rexec line 20: Deprecated option ServerKeyBits
Okt 22 10:04:34 OSMC94 sshd[15480]: rexec line 32: Deprecated option RSAAuthentication
Okt 22 10:04:34 OSMC94 sshd[15480]: rexec line 39: Deprecated option RhostsRSAAuthentication
Okt 22 10:04:35 OSMC94 sshd[15480]: reprocess config line 32: Deprecated option RSAAuthentication
Okt 22 10:04:35 OSMC94 sshd[15480]: reprocess config line 39: Deprecated option RhostsRSAAuthentication
Okt 22 10:04:35 OSMC94 sshd[15480]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.0.28 user=osmc
Okt 22 10:04:37 OSMC94 sshd[15480]: Failed password for osmc from 192.168.0.28 port 57343 ssh2
Okt 22 10:04:37 OSMC94 sshd[15480]: error: Received disconnect from 192.168.0.28 port 57343:3: com.jcraft.jsch.JSchException: Auth cancel [preauth]

is there a different password to be set?

It is working as root, but not as osmc user

Thanks

Could you explain what you mean? On OSMC, as on Ubuntu, root isn’t enabled.

I enabled root account on osmc
I connet to osmc via commandline
ssh osmc@ip
and
ssh root@ip

using ubuntu as system to connect both are working

using juicy ssh on android ssh as oscm user is not working, as root user it is.

strange to me.

does this clarify?

Yes it clarifies things but no I don’t know why that would be the case.

Does the “bad” password contain any umlauts or other “special” characters?

What do you mean by this?

Are you using a key file? If so, take a look here.