Sshfs via fstab doesn't automount

HI,
I’m trying to get this running. ssh works like a charm - just in case you were wondering in my fstab I have osmc@192.168.1.15:/media/extHDD/music /media/meko/music fuse.sshfs netdev,allow_other,IdentityFile=/home/meko/.ssh/mykey,default_permissions,uid=1000,gid=1000 0 0

it only works if I do sudo mount -a after boot manually.

Any idea what might be missing in my fstab. i’d rather have it automount on boot, like it works with SMB shares in my network.

The generally recommended method with OSMC is to include the fstab options noauto,x-systemd.automount and since this is a music source, enable “Wait for network” in My OSMC -> Network.

I’d also recommend you remove netdev (not so sure about allow_other either.)

nope that doesn’t do a thing except that with noauto sudo mount -a didn’t work anymore.
I actually want to connect to the 4k and osmc, there’s a hDD attached via USB, and I want to connect to to it via my PC. Since it works via sudo mount -aI assume it’s a setting or a permission I’m missing…

Ah, so you do.

So what’s the box you’re connecting from? Clearly a look at the machine’s system journal might help here.

Just out of interest - why are you using sshfs? It should ‘just work’ with SMB.

SSHFS will be quite slow

Sam

I’m gonna switch to SMB if I can’t get sshfs to work. I just thought I save on running Samba on osmc. And once it’s mounted it’s fine speedwise

Linux Mint 18.3 (Ubuntu 16.04)

Well, a copy/paste of the sys journal to https://paste.osmc.tv would at least give us a chance of finding a solution.

And wouldn’t it be better to use NFS, rather tna SMB, for Linux - Linux?

it works if I add delay_connect

So, for the record:

osmc@192.168.1.15:/media/extHDD/music /media/meko/music fuse.sshfs delay_connect,_netdev,allow_other,IdentityFile=/home/meko/.ssh/mykey 0 0

mounts the - at the Vero 4k – attached USB-HDD, more precisely some dirs, on my Linux Mint machine.

Regarding speed: this seems to be influenced by a number of things, sshfs is not necessarily slow

“The advantages of sshfs over NFS and Samba are a repsonsiveness much closer to local file systems than either of the common systems and somewhat faster transfer speeds (your mileage may vary). Also it has (at least for me) proven very stable with no outtages yet. The simplicity of sshfs setup can also be an advantage if you do not actually have a use for Samba’s bewildering array of configuration options. If you know how to use SSH, you know how to use sshfs. “
See: https://www.dd-wrt.com/wiki/index.php/Sshfs

Update: I added Compression=no,kernel_cache > all seems ok, I didn’t see any speed improvements though

Interesting. Out of interest, what encryption cipher are you using, and are you compressing the data?

phh, I got an RSA key with a passphrase, and no compression afaik (but I will look into this)

this seems interesting in that respect: Blazingly fast sshfs — Benjamin's blog

Update: there seems to be an issue if the 4k is powered off, my Linux PC’S file manager stalls. This could be related to a known Linux Mint issue