SSL with Kore

Hello,

I am attempting to set up SSL for use with Kore on an Android device, and I’m having some problems. I’ve done the following on a fresh installation of OSMC on a Raspberry Pi 3:

  1. Created certificates in ~/.kodi/userdata:
    openssl req -x509 -nodes -days 365 -newkey rsa:4096 -keyout server.key -out server.pem
  2. Enabled both application control options for remote control from applications on this and other systems (through Settings -> Services -> Control)
  3. Changed the HTTP server port to 443 (through Settings -> Services -> Control)
  4. Enabled SSL (through Settings -> Services -> Control)

I’m able to connect using Kore until I enable SSL. Kore disconnects and is unable to reconnect. I am able to connect using a web browser after ignoring the certificate warnings about not having a trusted CA.

I see from the release notes that Kore v2.5.1 added support for self-signed certificates, so I’m not sure if there’s something wrong with my certificate. I tried importing server.pem into my Android device as a user certificate, which didn’t seem to help.

After performing a reboot over SSH (sudo reboot now), the SSL setting disables itself.

Any advice would be greatly appreciated.

If you are sure that the warning was for a self-signed certificate, then this would seem to be an issue for the Kore developers. https://forum.kodi.tv/forumdisplay.php?fid=129

Thanks dillthedog, I have posted the question there.