Standalone Raspberry Pi 2

Received my very first Raspberry Pi 2 today. Installed it in a case, downloaded OSMC RC 2 and installed on an 8GB SD Class 10 card with the Windows installer. Connected the device to a TV with USB keyboard. No network, no HDD.
After OSMC installed the files, the device continues in a reboot loop after showing a ‘sad face’. Any ideas?

My objective is to run the device in a standalone config with no network connection and content stored locally on a 1TB hdd. Will this configuration work under OSMC?

That configuration should work. You’d ideally want it connected to a network to start with so you can scrape all the media on the HDD. After that you could disconnect it from the network.

A sad face restart loop on a brand new install is almost certainly going to be a hardware issue.

What power adaptor are you using ? The Pi 2 is very fussy about the power adaptor used.

Try an alternative power adaptor and/or SD card if possible.

1 Like

Thank you for that confirmation.
I already have the content scraped with all media in separate folders and KODI set to scrape locally. I’ve been using Media Companion for the scraping.
I’m trying to have KODI as light as possible and the Raspberry Pi as uncomplicated as possible.

I have a 5V 2000mA PSU. The only peripheral connected is a USB keyboard.

I suspect the SD card got corrupt along the way although OSMC seemed to have finished it’s file installation. I just tried to format the 8GB SD card with SDFormatterv4 and it only shows 242MB available.

I’m waiting for RASPBIAN to finish downloading (my Internet is ‘slow’ band) and will install that on a 16GB SD card. I’m planning to have a Linux m/c running also as I think this will let me setup and troubleshoot more easily that on my WIN7 laptop. I’m hoping this Linux m/c will let me recover the corrupt 8GB SD card.

I’ll update when I have more results.

Thank you for your assistance.

I just tried to format the 8GB SD card with SDFormatterv4 and it only shows 242MB available.

You must enable the size adjustment flag in sdformatter.

Tried that option and still 242MB.
I tried FULL(erase)- The device does not support “Flash Erase”
I tried FULL(overwrite)-Formats to 242MB.
I hope this SD is not toast as it’s brand new, or was.

Not toast: just needs the MBR restoring. In Raspbmc installer we had an option for this. Looks like I should add it back.


1 Like

I think that would be a good recovery option to have just in case.

Not for giving up, I inserted the suspect SD card into my LG G Pro Android device and erased the device. :smiley: It recovered the MBR and I have now formatted with SDFormatterv4 with FULL(overwrite) and SIZE ADJUSTMENT. This could be a band aid till you add the MRB restoring function.

This adds to my justification for building a RAPSBIAN box for supporting these projects.


Installed OSMC again. Tried it on two RPi2’s. Same result. Does not seen to be a hardware issue.

RASPBIAN works fine on the RPi2.

I’ll try the OSMC installer again this time re-grabbing the software.

I have downloaded the IMG and used Win32DiskImager.exe and now have a stable system.

Except, an error box top center of display [Script failed! : Skin Shortcuts]

I only have a USB keyboard connected at this time but does not do anything on the menu.

Any suggestions while I try searching for possible answers?

Power cycled the RPi2 and got the keyboard working and was able to navigate around the menus. Now it seems somewhat stable. Maybe I need to look closer at my PSU which is labelled at 2A.