Starting fresh new Vero4K+

Just got a new Vero4K+. Connected HDMI cable (the one supplied), the network cable (supplied, and verified it is connected to the network), and a kbd/mouse USB dongle. Connected power (the one supplied).

I get the “Please standby” screen, a lot of messages on the left, then the unhappy face, which keeps blanking out the reappearing.

What else do I need to do?



There is a small booklet that came with your vero In wich you will find exact instructions what should or shouldn’t be plugged in to the device during its initial boot up

You can re-install OSMC by following Reinstalling OSMC - Vero 4K - OSMC. This should solve the problem in just a few minutes.

Did you lose power / unplug it during the initial setup?


No. didn’t lose power.

But once I managed to get the command prompt, I updated the system (apt-get update, apt-get dis-upgrade). That seemed to fix something. Rebooted, and OSMC came up, ran through the first run setup and seems fine. Tried an OSMC update, but it said everything was updated (kind of expected that).

As for running this the first time, I didn’t have a network cable attached - I thought it would boot up the wireless adapter. But I didn’t see any attempt to connect to my network, though. Should it have prompted me for something? Like network name, password etc?


I would reinstall OSMC.

Yes – you’ll be prompted to configure networking with the on-screen tutorial when the device boots.


Well, almost everything seems to be working now.

What doesn’t:

  • Can’t ssh into it (connection reset)
  • Can’t get any nfs exports on my network
  • Can’t get any SMB shares

But it does see my MySQL db’s. Just need to check debian setup to see what’s not quite right.

I was really hoping for a plug-n-play (w/o prayers). But, still, this is about the best thing on the market.

Thanks, Sam.

Did you reinstall OSMC?

Did you install/enable the ssh server?

How are you trying to access them? Did you read the HowTo here on Discourse?

If the user had a failed boot, he should reinstall OSMC

On a fresh install SSH is disabled by default until enabled in the walkthrough has a default on setting. So he can just enable it but I would suggest a reinstall to guarantee system integrity, particularly as there is no issue as the system is not yet customised.

Did a fresh install.

I can ssh into the new install.

But browsing, NFS does nothing; SMB returns an error (share not available).

From the ssh shell, I can mount to my nfs share (via mount command). But kodi/osmc won’t search for my nfs shares, as it did before (I have a Vero 4, as well as an RPi3). This is a problem, since some files set up to be accessed via nfs.


If you have a vero already working you might want to just copy over the etc/fstab, and .kodi\userdata from that machine (or at least advancedsettings.xml, sources.xml, and passwords.xml).

See File sharing with a NAS, media server, windows share or other device

I can - and do - have the nfs mount set up in fstab.

But, in previous versions of kodi, wherever there was a selection “Click to Browse”, there were sub-selections such as “home”, “root” “nfs”, and “smb” (maybe others).

Clicking on either “nfs” or “smb”, kodi would list all of the servers on the same network. In the case of samba, this was handled by nmdb, which (continually) broadcasts requests for who is on the network. There is a command in linux that would do the same for nfs servers (that is, find all nfs servers on a network). Unfortunately, I can’t remember it at the moment.

This method still works with my current Vero 4, and RPi3 .


Samba lists all shares using libsmbclient in Kodi.

Kodi uses libNFS for its NFS implementation

Are your 4K and Pi on the same version of osmc as your new device?

The 4K and Pi have been updated to the latest version available (can’t check the version at the moment). The 4K+ is the latest image posted on the website. Note that this has been a feature in kodi for many previous versions, as well as osmc.


The 4K and 4K + run the same software. So if it works on the 4K then it will work on the 4K +

If SMB browsing isn’t working, you may need to check your SMB version and also may need to enable legacy support

All I can think of is your devices are connected differently, ie some are wired and some are on WiFi. Some routers don’t allow mDNS broadcasting to cross these barriers and this can cause discovery issues.

OK, I just rechecked my other installations. For some reason, they are now only picking up one nfs server on my network, which happens to be my just installed 4K+. Weird. Even more, that install shouldn’t even be a server (the 4K+).

This must be something that has changed with my servers, since they were working.

FWIW: all are on the same physical network, going through the same router. Need to check if something changed with NFS on my servers. I am running fedora, and their updates are notorious for making changes that affect previous releases.

The Vero 4K + doesn’t have an NFS server in the App Store, so unless you installed the NFS kernel server package, it’s not picking up NFS.

I think you may be confusing NFS and SMB with DLNA

I think I installed nfs-kernel-server on the 4K+ manually at some point, which is why the 4K+ shows up in the list of nfs servers. As I said above, I think fedora might have changed something in their nfs configuration. Will check that out.

“There is no CONFUSION[sic]”. Sorry, just couldn’t resist the trump-ism. I have worked with NFS and Samba for quite awhile. I just need to recheck all settings on my servers.

Thx for help. will advise if something needs your attention.