Static IP - no Menu on my OSMC RC on Pi2

Hallo
I’m struggling trying to do this very simple thing: configuring a static IP on RC running on Pi2

I’ve not found indications of the files to be edited. I’ve read my OSMC menu should be used, but if I go there the showed page has no information - there’s a frame but no text in it

I’ve tried to modify /var/lib/connman/ethernet.config as below(I want to give 49 as static IP) but NO SUCCESS… at reboot still DHCP is used with .100 … someone can help?

many thanks
marco

[service_ethernet]
type=ethernet
IPv4=192.168.1.49/255.255.255.0/192.168.1.1
Nameservers=192.168.1.1

Please don’t edit anything under /var/lib/connman - you’re not supposed to edit connman configuration files directly. (This comes from the authors of connman)

Your choices are to either use the Networking GUI, or use connmanctl as the command line interface.

Obviously if there is a problem with the networking GUI we would like to get that fixed, so we need more information from you.

So some questions:

  1. Have you run any updates recently ?
  2. What skin are you using ?
  3. Do you happen to have a wifi connection configured at the same time ?
  4. What do you mean by “there’s a frame but no text in it” - can you provide a picture please ?
  5. Does your Ethernet work ok using DHCP ?
  6. Are you using an NFS install by any chance ?
  7. If possible, please use the log uploader to upload your log files.

Thanks.

hallo DB Mandreake, thanks for your reply.
I’ve uploaded the image and see below the answers to your questions

too late… I’ve already been able to do a mess :smiley: but I recovered it :smile:

many thanks! I’ve used the connmanctl and it worked perfectly

1.No
2.No skin , default one. I mean I have the skin I found when the system mounts the RC (Rpi 2) image.
3.No wifi connection,only ethernet
4.See the picture. I mean there are buttons and windows but no text .
5.Yes. Perfectly
6.I modified the fstab to mount a remote share which is phisically connected to the router. But even if I remove the line from FStab and reboot nothing changes in the GUI,
7.How do I do that?

1 Have you run any updates at all? You should.

7 https://osmc.tv/help/wiki/logs

Can you try installing updates and try again ?

Also I don’t suppose you have your language set to something other than the default English ?

If so which language, and can you try temporarily changing language back to English to see if it appears.

hallo again,
I’ve tried installing updates but it gives me the following error when it starts:

“an error occured while installing the following package: (unknown package)
Please report this problem to OSMC forum.Attempting to restart kodi”

Language is set to default english, never changed!

Please use the log uploader to upload your APT term.log and APT history.log.

Hallo,
Did a fresh install because not sure what configurations changes I made during the many tests I did…
So I’ve restarted from scratch and now everything looks fine…All menus are there and I didn’t touch the connman files at all.
Sorry I’ve bothered you with this topic, I will post log if issue appear again.