Static IP routes for Vero?


#1

Hi,

how can I configure persistent additional IP routes on Vero 4K?

For OSMC on Raspberry it works fine with an appropriate file in /lib/dhcpcd/dhcpcd-hooks/40-route, but on Vero the path doesn’t even exist.

Thx,
Andreas


#2

There’s no real easy way with connman and dhcp. You’d have to try something like this thread.

You can also do something that won’t be persistent after an update, and add your static route command to /lib/systemd/system/connman-wait-for-network.service right before the exit 0 on the “ExecStart” line. For this to work, you need to enable “wait for network” in MyOSMC.

You could also add the route command as a systemd service that requires something like “network-online.target”.


#3

Thanks for confirming this. Then I’ll find a workaround.

/Andreas


#4

/etc/rc.local already waits for network-online.target

Edit: One other thing:

It doesn’t exists on the RPi version of OSMC, either – unless you installed it, possibly as part of something like PiHole.


#5

Thanks again and indeed on the Raspi there is also PiHole installed , which I didn’t consider for the moment.


#6

Finally for a clean OSMC installation easiest seems to put additional routes in /etc/rc.local This also turned out to be a good place for my previous issue to restart Strongswan after networking is fully available.

Thanks
Andreas