Static MAC address

Hi all !

Also posted on reddit:

I’m in a bit of a pickle. I recently installed OSMC on a Pi3 and I’m very happy with it (I had Kodi on an older system, and decoding highly compressed videos was becoming an issue).

However, I just realised that the MAC address of the eth0 adapter changes every time the Pi reboots (shown on the “System info” page and on my DHCP server).

Is that supposed to be the normal behaviour ? How is that helpful ? If this is a feature, how can I assign a fixed address, preferably HW ? And, if this is a bug, would anyone have any idea where I should start ?

When I try to set a manual IP address using OSMC settings, the setting reverts itself to DHCP upon next reboot (?).

What I’ve tried so far:

  1. Adding to the end of the command line in “/boot/cmdline.txt” : smsc95xx.macaddr=xx:xx:...

  2. Adding to the end of “/boot/config.txt”: smsc95xx.macaddr=xx:xx:...

uname -a:
Linux dariboubare 4.9.29-10-osmc #1 SMP PREEMPT Mon Oct 9 02:18:18 UTC 2017 armv7l GNU/Linux
grep VERSION_ID /etc/os-release:

This is not normal to have a MAC address changing. I’m thinking you may have a failing SD card, so try a new installation on a new SD card. If that doesn’t work, it could be that your Pi is failing.

Of course, logs could help figure out what’s happening.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Thank you for your help, and apologies for missing out on the “how to report” instructions.

Here’s the whole she-bang:

I’ve update from deb stretch-devel main due to a sound stutter issue, which was fixed.

While scanning the log, I stumbled upon this:

 Hmm. There is a symbolic link /lib/modules/4.9.29-10-osmc/build
 However, I can not read it: No such file or directory
 Therefore, I am deleting /lib/modules/4.9.29-10-osmc/build

 Hmm. The package shipped with a symbolic link /lib/modules/4.9.29-10-osmc/source
 However, I can not read the target: No such file or directory
 Therefore, I am deleting /lib/modules/4.9.29-10-osmc/source

which looks scary to me, but I’m not familiar with Linux. I wasn’t able to find anything else of interest.

I think we’re getting somewhere. I figured the logs were pretty bare so I gave it another try, and something pretty ugly happens upon reboot.

The “debug log” settings isn’t saved, so I’m not able to upload the actual log.

All I can provide is a picture of the screen, and I’m at a total loss here:

I don’t even know if this is hardware or software related …

EDIT: this happens in a loop, with a different “ret =” value almost every time (seems to hang between -110 and -140). It also sometimes spurts what I assume are core dumps. Let me know if I can do anything to provide more info on this !

EDIT 2: OSMC is otherwise working like a charm, I’m baffled =)

As @bmillham indicated most likely your SD card is gone. Get a new one and do a fresh install

Darn, it’s a brand new one at that…

I’ll try. Thanks guys!

Your ‘new’ SD card may have been a counterfeit card. Did you get it on e-Bay or a similar online store? Some of those cards are not the full capacity that they report to the OS, causing all kinds of strange problems.

Or you could have just gotten a bad card. You should be able to get it replaced under warranty.

It’s a genuine-looking Kingston SDCIT/8GB , N0623-003.A00LF that I got from a computer store in town.

I’ll get a new one and I’ll report back here with the result!

I find it amazing that Kodi is actually running (for hours on end) without a glitch despite the hardware issue…

Well, once you boot and Kodi is running, there is not much access to the SD card (depending on your setup).

I’d take the card back to the store and exchange it for a new one. My personal preference is for SanDisk. Samsung cards are also good.

Do let us know if a new card fixes the problem.

1 Like

Test it with h2testw

I just tested it F3 and it looks fine.

I’ll get another one anyway and see what gives.

I hope the Pi isn’t fried :crossed_fingers:

I went to the store and got a new SD card, and, behold, the issue is gone.

Thanks a bunch guys !

While we’re at it, @sam_nazarko can you tell me if this commit made it into the latest img ?

I was having issues with the sound stuttering, and following directions from you here seemed to have fixed it, but I’d like to avoid tinkering with my new install if at all possible.

Surely that commit came after the July Update so it is not part of the current available image. But as long as you are not using torrent or other heavy background services you should not have stuttering

Maybe it was related to the other issue(s) I had. I’ll leave it alone for now and see how it goes.

Thanks again to the both of you for your time & support !

Would have been interesting what H2testw would have said.

1 Like

Test results are in:

Warning: Only 7455 of 7456 MByte tested.
Test finished without errors.
You can now delete the test files *.h2w or verify them again.
Writing speed: 4.08 MByte/s
Reading speed: 4.30 MByte/s
H2testw v1.4

I feel silly, I expected it to throw at least an error or two … I have no clue what’s going on here, but at least I have it working now =)

So that was on your old card? I thought you exchanged it at the shop?
Well it h2testw is happy maybe you can use it as a backup card

I didn’t have the receipt anymore, so I had to get a new one, but they’re dirt cheap now so I’m not too hurt =)

I’m going to keep it until another Pi finds a home with me, I’ll give it one more go.