Stereoscopic playback of mk3d movie file fails

I tried to play a mk3d file in stereoscopic mode with the Vero 4K, but it didn’t work. Only a 2D image is played back. When I deactivate the 3D mode of the TV, there are no double contours on the screen. It seems that only the images for one of the two eyes are played. My question: Can the Vero 4K not play mk3d files stereoscopically?

My settings before starting the movie file are:
Select playback mode > Select alternate mode > Same as movie


Try renaming the file to MKV to see if this makes a difference, and make sure 3D is in the filename.

This change doesn’t make a difference.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Please post logs and the name of the file.

Thank you for describing the procedure. I will upload logs after I found out whether the mkv file contains video streams for both eyes. At the moment it seems that this isn’t the case.

Well mediainfo can quickly tell you

Login to OSMC via ssh and Install mediainfo sudo apt-get install mediainfo and then run mediainfo <File>