Still having problems with ISO and VideoTS files

debug log:
I am very new to Kodi. I was running Jarvis and couldnt play my ISO and VideoTS files correctly. Other formats like mp4 and avi played fine. I save childrens DVD’s and multi-episode DVD’s in ISO or Video_TS format so I can use the menu system from the original DVD. In Jarvis the menu would not show up and I would get a blank screen with audio. It was suggested that I wait a week for the Krypton release. I just installed the new OSMC/Krypton. Now my menu screen shows up and I can navigate between episodes and select one. But then I get a blank screen. So this is an improvement over Jarvis, but still messing up. I have tried to research this but I get totally confused about sync and refresh etc. Below is my step by step problem and temporary solution. I should also point out that in both Jarvis and Krypton when I boot up I get the OSMC splash screen, then a blank screen. I always have to switch between HDMI inputs to get the TV to sync and show video. Or turn the TV on and off.

  • Turned on Debug…then rebooted
  • OSMC splash screen displayed
  • Then a blank screen with audio
  • I cycle the TV to another HDMI input and back again to get the TV to ‘resync’?
  • Kodi skin is now visible
  • I navigate to TV shows and select Gummi Bears.
  • The opening navigation menu is functional, just like on DVD
  • I navigate to and select an episode
  • The screen goes blank, but with audio
  • Once again I switch to a different HDMI input on the TV and back again
  • TV says it’s getting data and now plays the episode correctly.
    When I exit this video to get back to Kodi, blank screen again
    Switch HDMI input and back again… and I have video again

One strange footnote… This scenario is on our main Visio smart TV. If I set up my Pi-3 to my HDMI on my 60hz computer monitor, everything works perfectly without having to switch HDMI channels to get a visual. So I dont know what the difference between my computer monitor and TV is or what this whole issue is about.

Thanks for the help!!!

Can you try disabling “adjust display refresh rate” in player settings/video.

YES!!! That’s the magic setting! Thanks! If you can explain what this was all about in layman’s terms I’d appreciate it. But if it isn’t easy to explain or you dont have the time… no problem. Very thankful for your help. Nothing like correct settings for an enjoyable rather than frustrating computer experience!!! It’s great having this work as though watching my DVD player!!

Videos come in a range of framerates.
Live TV is normally 50Hz (Europe) or 59.94Hz (US).
Cinema releases (and so BluRays and DVDs are usually 23.97Hz.
There also exist 24Hz, 25Hz, 30Hz and 60Hz

By default kodi runs at the framerate reported as preferred by the display. Normally 50Hz in Europe and 60Hz in US.
The differing framerates of the video and display causes a subtle judder effect, most noticeable on panning shots (it just looks a little jerky). Many people don’t really notice this, but some fine it quite jarring.

“adjust display refresh rate” means kodi will try to pick a better HDMI mode for each video it plays.
It results in smoother video, but TVs are generally slow to switch modes, causing a blank screen for a few seconds on playback start and stop. The best TVs takes about a second to switch. The worst may take 7 seconds or longer.

This setting has always been “opt in”, so users who don’t explore the settings will have it disabled.
Sam made a change to Krypton to enable this by default. As there have been a number of reports about this behaviour being unwanted I think this change will be reverted in the future.

Personally I always enable it manually. I prefer the smoother video and am willing to put up with the blank screen delay at start and stop of video playback, but each user has different priorities. I would recommend that it is a setting users experiment with and are aware of the two options.


Thanks for taking the time to explain the framerate issue. Waiting for a blank screen to come alive is probably like watching water boil. I may be wrong, but I am pretty sure I waited much longer than 7 seconds in the hope it would wake up. Regardless… it all works now and I’ll keep my eye out to see if I notice any ‘stuttering video’. Thanks so much… it’s a real joy having this work now!!